Catalog
Vulnerability catalog
Search by CVE, product, or vendor. Filter by severity, CISA KEV, source, stack, and weakness. Filtered views stay out of the search index.
- Medium4.3CVE-2023-47037 is listed by We failed to apply CVE-2023-40611 in 2.7.1 and this vulnerability was marked as fixed then..Check if you run itEPSS 1.50%Nov 12, 2023
- Medium6.5CVE-2023-42781 is listed by inventory_high.Check if you run itEPSS 1.66%Nov 12, 2023
- High7.5Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow.Check if you run itEPSS 1.56%Oct 28, 2023
- Medium4.3CVE-2023-46288 is listed by Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Airflow.This issue affects Apache Airflow from 2.4.0 to…Check if you run itEPSS 1.84%Oct 23, 2023
- Medium4.3Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive configuration information when the "ex…Check if you run itEPSS 1.60%Oct 14, 2023
- Medium6.5Apache Airflow, in versions prior to 2.7.2, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request th…Check if you run itEPSS 1.90%Oct 14, 2023
- Medium6.5Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user h…Check if you run itEPSS 1.44%Oct 14, 2023
- Medium6.5Apache Airflow, versions before 2.7.2, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task ins…Check if you run itEPSS 2.01%Oct 14, 2023
- Medium6.5Apache Airflow, versions before 2.7.1, is affected by a vulnerability that allows authenticated users who have access to see the task/dag in the UI, to craft a URL, wh…Check if you run itEPSS 2.00%Sep 12, 2023
- Medium4.3Apache Airflow, versions before 2.7.1, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when…Check if you run itEPSS 1.74%Sep 12, 2023
- High8.0The session fixation vulnerability allowed the authenticated user to continue accessing Airflow webserver even after the password of the user has been reset by the adm…Check if you run itEPSS 1.85%Aug 23, 2023
- Medium5.9Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certifi…Check if you run itEPSS 0.80%Aug 23, 2023
- High8.1Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges.Check if you run itEPSS 1.96%Aug 23, 2023
- High8.8Execution with Unnecessary Privileges, : Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Software Foundation Apache Airflow.The "Run…Check if you run itEPSS 2.63%Aug 5, 2023
- Medium6.5Apache Airflow, versions before 2.6.3, has a vulnerability where an authenticated user can use crafted input to make the current request hang.Check if you run itEPSS 1.57%Jul 12, 2023
- Medium6.5Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows unauthorized read access to a DAG through the URL.Check if you run itEPSS 1.03%Jul 12, 2023
- Medium6.5Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an attacker to cause a service disruption by manipulating the run_id parameter.Check if you run itEPSS 1.42%Jul 12, 2023
- Medium6.5Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an attacker to perform unauthorized file access outside the intended directory struct…Check if you run itEPSS 1.79%Jul 12, 2023
- Medium6.5Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an unauthorized actor to gain access to sensitive information in Connection edit view.Check if you run itEPSS 1.20%Jul 12, 2023
- Medium6.5In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations.Check if you run itEPSS 1.53%Jun 19, 2023
- Critical9.8Privilege Context Switching Error vulnerability in Apache Software Foundation Apache Airflow.This issue affects Apache Airflow: before 2.6.0.Check if you run itEPSS 2.28%May 8, 2023
- Medium5.4Task instance details page in the UI is vulnerable to a stored XSS.This issue affects Apache Airflow: before 2.6.0.Check if you run itEPSS 1.98%May 8, 2023
- Medium5.3Generation of Error Message Containing Sensitive Information vulnerability in Apache Software Foundation Apache Airflow.This issue affects Apache Airflow: before 2.5.2.Check if you run itEPSS 1.38%Mar 15, 2023
- Critical9.8Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow, Apache Software Foundat…Check this weekEPSS 11.91%Jan 21, 2023
- High7.8Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Hive Provider, Apache Airflow allows an atta…Check if you run itEPSS 1.76%Nov 22, 2022
Sort