Vulnerability · AZL-111074
CVE-2026-97229 affecting package ruby 3.3.5-10
Published Oct 13, 2026 · catalog updated Oct 25, 2026 · affecting package ruby 3.3.5-10
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Open the advisory
Exploitation likelihood is not on this record for AZL-111074. A missing EPSS score is not a low risk. Compare affecting package ruby 3.3.5-10 with the linked advisory before you change production.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (affecting package ruby 3.3.5-10).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- EPSS is missing. A missing score is not a low risk.
- Severity
- Unknown—
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- Awaiting synchronization with FIRST
- Remediation
- Not established
- Affected products
- Azure Linux:3 ruby
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Azure Linux:3 ruby0 → 3.3.5-10
How to fix AZL-111074
Upgrade
AZL-111074 lists a fix boundary at 3.3.5-10. Compare the installed build with that boundary before you change production.
Version check
Fixed in 3.3.5-10
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
Exploitation likelihood is not on this record for AZL-111074. A missing EPSS score is not a low risk. Compare affecting package ruby 3.3.5-10 with the linked advisory before you change production.
Which versions are affected?
Compare what you have installed with 0 → 3.3.5-10. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS is not on this record yet. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Oct 13, 2026 · OpenSSF OSV / OSV Scanner
Detected
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
Oct 25, 2026 · OpenSSF OSV / OSV Scanner
Fix available
ruby fixed in 3.3.5-10
Oct 25, 2026 · OpenSSF OSV / OSV Scanner
Updated
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
Sources
- OpenSSF OSV / OSV ScannerPackage advisoryAZL-111074
CVE-2026-97229 affecting package ruby 3.3.5-10
osv.dev
References
Freshness
Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- OpenSSF OSV / OSV ScannerOct 26, 2026