Vulnerabilities

Vulnerability · CVE-2006-4339

OpenSSL before 0.9.7, 0.9.7 before 0.9.7k, and 0.9.8 before 0.9.8c, when using an RSA key with exponent 3, removes PKCS-1 padding before generating a hash, which allows remote atta

Published Sep 5, 2006 · catalog updated Oct 30, 2026 · OpenSSL before 0.9.7, 0.9.7

Last checked Oct 31, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2006-4339. EPSS is 5.09%. Act only if a listed version of OpenSSL before 0.9.7, 0.9.7 is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (OpenSSL before 0.9.7, 0.9.7).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Critical9.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
5.09%
Remediation
Version ranges on file
Affected products
Debian:12 openssl · Debian:13 openssl · Debian:14 openssl · cpe openssl/openssl

A flaw was found in OpenSSL. When configured to use an RSA key with exponent 3, OpenSSL improperly removes PKCS-1 padding before generating a hash. This allows remote attackers to forge PKCS #1 v1.5 signatures. Consequently, OpenSSL may incorrectly verify X.509 and other certificates, leading to a bypass of trust and authentication mechanisms.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Debian:12 openssl0 → 0.9.8b-3
  • Debian:13 openssl0 → 0.9.8b-3
  • Debian:14 openssl0 → 0.9.8b-3
  • cpe openssl/openssl0.9.1c
  • cpe openssl/openssl0.9.2b
  • cpe openssl/openssl0.9.3
  • cpe openssl/openssl0.9.3a
  • cpe openssl/openssl0.9.4
  • cpe openssl/openssl0.9.5
  • cpe openssl/openssl<= 0.9.7

How to fix CVE-2006-4339

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2006-4339. EPSS is 5.09%. Act only if a listed version of OpenSSL before 0.9.7, 0.9.7 is installed.

Which versions are affected?

Compare what you have installed with 0 → 0.9.8b-3, 0.9.1c, 0.9.2b, 0.9.3, 0.9.3a, 0.9.4. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-310; CWE-347: Improper Verification of Cryptographic Signature. EPSS 5.09%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Sep 5, 2006 · Trivy Vulnerability DB

    Detected

    OpenSSL before 0.9.7, 0.9.7 before 0.9.7k, and 0.9.8 before 0.9.8c, when using an RSA key with exponent 3, removes PKCS-1 padding before generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents OpenSSL from correctly verifying X.509 and other certificates that use PKCS #1.

  2. Oct 30, 2026 · Trivy Vulnerability DB

    Fix available

    openssl fixed in 0.9.8b-3; openssl fixed in 0.9.8b-3; openssl fixed in 0.9.8b-3

  3. Oct 30, 2026 · Trivy Vulnerability DB

    Fix available

    openssl fixed in 0.9.8b-3

  4. Oct 30, 2026 · Trivy Vulnerability DB

    Updated

    OpenSSL before 0.9.7, 0.9.7 before 0.9.7k, and 0.9.8 before 0.9.8c, when using an RSA key with exponent 3, removes PKCS-1 padding before generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents OpenSSL from correctly verifying X.509 and other certificates that use PKCS #1.

Sources

  • CVE.orgVulnerability recordCVE-2006-4339

    Official CVE identifier

    cve.org
  • NIST NVDVulnerability recordCVE-2006-4339

    A flaw was found in OpenSSL. When configured to use an RSA key with exponent 3, OpenSSL improperly removes PKCS-1 padding before generating a hash. This allows remote attackers to forge PKCS #1 v1.5 signatures. Consequently, OpenSSL may incorrectly verify X.509 and other certific

    nvd.nist.gov
  • Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2006-4339

    OpenSSL before 0.9.7, 0.9.7 before 0.9.7k, and 0.9.8 before 0.9.8c, when using an RSA key with exponent 3, removes PKCS-1 padding before generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents OpenSSL from cor

    osv.dev

References

Freshness

Last verified in this catalog Oct 30, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • NIST NVDOct 31, 2026
  • CVE.orgOct 30, 2026
  • Trivy Vulnerability DBOct 30, 2026