Vulnerabilities

Vulnerability · CVE-2011-4292

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.

Published Jul 16, 2012 · catalog updated Jun 16, 2026 · Moodle 2.0.x before 2.0.3

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2011-4292. EPSS is 1.99%. Act only if a listed version of Moodle 2.0.x before 2.0.3 is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Moodle 2.0.x before 2.0.3).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium4.0
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.99%
Remediation
Advisory link
Affected products
cpe moodle/moodle

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe moodle/moodle2.0.0
  • cpe moodle/moodle2.0.1
  • cpe moodle/moodle2.0.2

How to fix CVE-2011-4292

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2011-4292. EPSS is 1.99%. Act only if a listed version of Moodle 2.0.x before 2.0.3 is installed.

Which versions are affected?

Compare what you have installed with 2.0.0, 2.0.1, 2.0.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-89: SQL Injection. EPSS 1.99%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Jul 16, 2012 · Monitored products — high

    Detected

    Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.

  2. Jun 16, 2026 · Monitored products — high

    Updated

    Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.

Sources

  • CVE.orgVulnerability recordCVE-2011-4292

    Official CVE identifier

    cve.org
  • Monitored products — highVendor advisoryCVE-2011-4292

    Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — highNov 4, 2026