Vulnerabilities

Vulnerability · CVE-2012-1170

Moodle before 2.2.2 has an external enrolment plugin context check issue where capability checks are not thorough

Published Nov 14, 2019 · catalog updated Jun 16, 2026 · Moodle before 2.2.2 has

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2012-1170. EPSS is 0.91%. Act only if a listed version of Moodle before 2.2.2 has is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Moodle before 2.2.2 has).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.91%
Remediation
Version ranges on file
Affected products
cpe fedoraproject/fedora · cpe moodle/moodle

Moodle before 2.2.2 has an external enrolment plugin context check issue where capability checks are not thorough

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe fedoraproject/fedora15
  • cpe fedoraproject/fedora16
  • cpe fedoraproject/fedora17
  • cpe moodle/moodle< 2.2.2

How to fix CVE-2012-1170

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2012-1170. EPSS is 0.91%. Act only if a listed version of Moodle before 2.2.2 has is installed.

Which versions are affected?

Compare what you have installed with 15, 16, 17, < 2.2.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-354. EPSS 0.91%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 14, 2019 · Monitored products — high

    Detected

    Moodle before 2.2.2 has an external enrolment plugin context check issue where capability checks are not thorough

  2. Jun 16, 2026 · Monitored products — high

    Updated

    Moodle before 2.2.2 has an external enrolment plugin context check issue where capability checks are not thorough

Sources

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — highNov 4, 2026