Vulnerability · CVE-2012-1500
Stored XSS vulnerability in UpdateFieldJson.jspa in JIRA 4.4.3 and GreenHopper before 5.9.8 allows an attacker to inject arbitrary script code.
Published Feb 13, 2020 · catalog updated Jun 16, 2026 · Stored XSS vulnerability in
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2012-1500. EPSS is 1.12%. Act only if a listed version of Stored XSS vulnerability in is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Stored XSS vulnerability in).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium5.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.12%
- Remediation
- Version ranges on file
- Affected products
- cpe atlassian/greenhopper · cpe atlassian/jira
Stored XSS vulnerability in UpdateFieldJson.jspa in JIRA 4.4.3 and GreenHopper before 5.9.8 allows an attacker to inject arbitrary script code.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe atlassian/greenhopper< 5.9.8
- cpe atlassian/jira4.4.3
How to fix CVE-2012-1500
Upgrade
CVE-2012-1500 lists a fix boundary at 5.9.8. Compare the installed build with that boundary before you change production.
Version check
Affected < 5.9.8
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2012-1500. EPSS is 1.12%. Act only if a listed version of Stored XSS vulnerability in is installed.
Which versions are affected?
Compare what you have installed with < 5.9.8, 4.4.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-79: Cross-site Scripting (XSS). EPSS 1.12%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Feb 13, 2020 · Monitored products — critical
Detected
Stored XSS vulnerability in UpdateFieldJson.jspa in JIRA 4.4.3 and GreenHopper before 5.9.8 allows an attacker to inject arbitrary script code.
Jun 16, 2026 · Monitored products — critical
Updated
Stored XSS vulnerability in UpdateFieldJson.jspa in JIRA 4.4.3 and GreenHopper before 5.9.8 allows an attacker to inject arbitrary script code.
Sources
- CVE.orgVulnerability recordCVE-2012-1500
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2012-1500
Stored XSS vulnerability in UpdateFieldJson.jspa in JIRA 4.4.3 and GreenHopper before 5.9.8 allows an attacker to inject arbitrary script code.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026