Vulnerability · CVE-2012-2448
VMware ESXi 3.5 through 5.0 and ESX 3.5 through 4.1 allow remote attackers to execute arbitrary code or cause a denial of service (memory overwrite) via NFS traffic.
Published May 4, 2012 · catalog updated Jun 16, 2026 · VMware ESXi 3.5 through
Last checked Oct 31, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2012-2448. EPSS is 3.47%. Act only if a listed version of VMware ESXi 3.5 through is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (VMware ESXi 3.5 through).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2016-7463 · Medium
- CVE-2014-1208 · Low
- CVE-2014-1207 · Medium
- CVE-2013-3519 · High
- CVE-2012-1515 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 3.47%
- Remediation
- Advisory link
- Affected products
- cpe vmware/esxi
VMware ESXi 3.5 through 5.0 and ESX 3.5 through 4.1 allow remote attackers to execute arbitrary code or cause a denial of service (memory overwrite) via NFS traffic.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe vmware/esxi3.5
- cpe vmware/esxi4.0
How to fix CVE-2012-2448
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 3.5 · 1 other packages on the advisory
Advisory
Open the inventory_critical record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2012-2448. EPSS is 3.47%. Act only if a listed version of VMware ESXi 3.5 through is installed.
Which versions are affected?
Compare what you have installed with 3.5, 4.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-119: Buffer Overflow. EPSS 3.47%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
May 4, 2012 · Monitored products — critical
Detected
VMware ESXi 3.5 through 5.0 and ESX 3.5 through 4.1 allow remote attackers to execute arbitrary code or cause a denial of service (memory overwrite) via NFS traffic.
Jun 16, 2026 · Monitored products — critical
Updated
VMware ESXi 3.5 through 5.0 and ESX 3.5 through 4.1 allow remote attackers to execute arbitrary code or cause a denial of service (memory overwrite) via NFS traffic.
Sources
- Monitored products — criticalVendor advisoryCVE-2012-2448
VMware ESXi 3.5 through 5.0 and ESX 3.5 through 4.1 allow remote attackers to execute arbitrary code or cause a denial of service (memory overwrite) via NFS traffic.
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Monitored products — criticalOct 31, 2026