Vulnerability · CVE-2012-5568
Apache Tomcat through 7.0.x allows remote attackers to cause a denial of service (daemon outage) via partial HTTP requests, as demonstrated by Slowloris.
Published Nov 30, 2012 · catalog updated Oct 9, 2026 · Apache Tomcat through 7.0.x
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2012-5568. EPSS is 9.59%. Act only if a listed version of Apache Tomcat through 7.0.x is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Apache Tomcat through 7.0.x).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-73180 · Medium
- CVE-2026-68763 · High
- CVE-2026-68569 · High
- CVE-2026-68525 · Critical
- CVE-2026-66422 · High
- Severity
- Medium5.0
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 9.59%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/tomcat · cpe opensuse/opensuse
Apache Tomcat through 7.0.x allows remote attackers to cause a denial of service (daemon outage) via partial HTTP requests, as demonstrated by Slowloris.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/tomcat>= 7.0.0, <= 7.0.105
- cpe opensuse/opensuse11.4
- cpe opensuse/opensuse12.1
- cpe opensuse/opensuse12.2
How to fix CVE-2012-5568
Upgrade
CVE-2012-5568 lists a fix boundary at 7.0.105. Compare the installed build with that boundary before you change production.
Version check
Affected <= 7.0.105
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2012-5568. EPSS is 9.59%. Act only if a listed version of Apache Tomcat through 7.0.x is installed.
Which versions are affected?
Compare what you have installed with >= 7.0.0, <= 7.0.105, 11.4, 12.1, 12.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 9.59%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Nov 30, 2012 · Monitored products — critical
Detected
Apache Tomcat through 7.0.x allows remote attackers to cause a denial of service (daemon outage) via partial HTTP requests, as demonstrated by Slowloris.
Oct 9, 2026 · Monitored products — critical
Updated
Apache Tomcat through 7.0.x allows remote attackers to cause a denial of service (daemon outage) via partial HTTP requests, as demonstrated by Slowloris.
Sources
- CVE.orgVulnerability recordCVE-2012-5568
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2012-5568
30-day exploitation probability 9.59%
first.org - Monitored products — criticalVendor advisoryCVE-2012-5568
Apache Tomcat through 7.0.x allows remote attackers to cause a denial of service (daemon outage) via partial HTTP requests, as demonstrated by Slowloris.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026