Vulnerability · CVE-2013-2233
Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle attacks by leveraging failure to cache SSH host keys.
Published May 4, 2018 · catalog updated Jun 16, 2026 · Ansible before 1.2.1 makes
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2013-2233. EPSS is 1.90%. Act only if a listed version of Ansible before 1.2.1 makes is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Ansible before 1.2.1 makes).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2024-0690 · Medium
- CVE-2023-5764 · High
- CVE-2022-3697 · High
- CVE-2021-20180 · Medium
- CVE-2021-20178 · Medium
- Severity
- High7.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.90%
- Remediation
- Version ranges on file
- Affected products
- cpe redhat/ansible
Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle attacks by leveraging failure to cache SSH host keys.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe redhat/ansible< 1.2.1
How to fix CVE-2013-2233
Upgrade
CVE-2013-2233 lists a fix boundary at 1.2.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.2.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2013-2233. EPSS is 1.90%. Act only if a listed version of Ansible before 1.2.1 makes is installed.
Which versions are affected?
Compare what you have installed with < 1.2.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-320. EPSS 1.90%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
May 4, 2018 · Monitored products — high
Detected
Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle attacks by leveraging failure to cache SSH host keys.
Jun 16, 2026 · Monitored products — high
Updated
Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle attacks by leveraging failure to cache SSH host keys.
Sources
- CVE.orgVulnerability recordCVE-2013-2233
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2013-2233
Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle attacks by leveraging failure to cache SSH host keys.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 2, 2026