Vulnerability · CVE-2016-8628
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller.
Published Jul 31, 2018 · catalog updated Jun 17, 2026 · Ansible before version 2.2.0
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2016-8628. EPSS is 3.21%. Act only if a listed version of Ansible before version 2.2.0 is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Ansible before version 2.2.0).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2024-0690 · Medium
- CVE-2023-5764 · High
- CVE-2022-3697 · High
- CVE-2021-20180 · Medium
- CVE-2021-20178 · Medium
- Severity
- Critical9.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 3.21%
- Remediation
- Version ranges on file
- Affected products
- cpe redhat/ansible
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe redhat/ansible< 2.2.0
How to fix CVE-2016-8628
Upgrade
CVE-2016-8628 lists a fix boundary at 2.2.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.2.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2016-8628. EPSS is 3.21%. Act only if a listed version of Ansible before version 2.2.0 is installed.
Which versions are affected?
Compare what you have installed with < 2.2.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-77: Command Injection. EPSS 3.21%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 31, 2018 · Monitored products — high
Detected
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
Jun 17, 2026 · Monitored products — high
Updated
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
Sources
- CVE.orgVulnerability recordCVE-2016-8628
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2016-8628
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 2, 2026