Vulnerability · CVE-2016-9587
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems.
Published Apr 24, 2018 · catalog updated Jun 17, 2026 · Ansible before versions 2.1.4,
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2016-9587 is not in CISA KEV. FIRST estimates a 17.01% chance of exploitation in the next 30 days. Check whether you run Ansible before versions 2.1.4,.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Ansible before versions 2.1.4,).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2024-0690 · Medium
- CVE-2023-5764 · High
- CVE-2022-3697 · High
- CVE-2021-20180 · Medium
- CVE-2021-20178 · Medium
- Severity
- High8.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 17.01%
- Remediation
- Version ranges on file
- Affected products
- cpe ansible/ansible · cpe redhat/ansible · cpe redhat/openstack
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe ansible/ansible< 2.2.1
- cpe redhat/ansible< 2.1.4
- cpe redhat/openstack11
How to fix CVE-2016-9587
Upgrade
CVE-2016-9587 lists a fix boundary at 2.2.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.2.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2016-9587 is not in CISA KEV. FIRST estimates a 17.01% chance of exploitation in the next 30 days. Check whether you run Ansible before versions 2.1.4,.
Which versions are affected?
Compare what you have installed with < 2.2.1, < 2.1.4, 11. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-20: Improper Input Validation. EPSS 17.01%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Apr 24, 2018 · Monitored products — high
Detected
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Jun 17, 2026 · Monitored products — high
Updated
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Sources
- CVE.orgVulnerability recordCVE-2016-9587
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2016-9587
30-day exploitation probability 17.01%
first.org - Monitored products — highVendor advisoryCVE-2016-9587
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
nvd.nist.gov
References
- Third Party Advisory · rhn.redhat.com
- Third Party Advisory · rhn.redhat.com
- Third Party Advisory · securityfocus.com
- Third Party Advisory · access.redhat.com
- Third Party Advisory · access.redhat.com
- Third Party Advisory · access.redhat.com
- Issue Tracking · bugzilla.redhat.com
- Third Party Advisory · security.gentoo.org
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- CVE.orgNov 4, 2026
- Monitored products — highNov 2, 2026