Vulnerabilities

Vulnerability · CVE-2017-1000355

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an XStream: Java crash when trying to instantiate void/Void.

Published Jan 29, 2018 · catalog updated Jun 17, 2026 · Jenkins versions 2.56 and

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2017-1000355. EPSS is 1.74%. Act only if a listed version of Jenkins versions 2.56 and is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Jenkins versions 2.56 and).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.74%
Remediation
Version ranges on file
Affected products
cpe jenkins/jenkins

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an XStream: Java crash when trying to instantiate void/Void.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe jenkins/jenkins<= 2.46.1
  • cpe jenkins/jenkins<= 2.56

How to fix CVE-2017-1000355

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2017-1000355. EPSS is 1.74%. Act only if a listed version of Jenkins versions 2.56 and is installed.

Which versions are affected?

Compare what you have installed with <= 2.46.1, <= 2.56. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-502: Deserialization of Untrusted Data. EPSS 1.74%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Jan 29, 2018 · Monitored products — critical

    Detected

    Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an XStream: Java crash when trying to instantiate void/Void.

  2. Jun 17, 2026 · Monitored products — critical

    Updated

    Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an XStream: Java crash when trying to instantiate void/Void.

Sources

  • CVE.orgVulnerability recordCVE-2017-1000355

    Official CVE identifier

    cve.org
  • Monitored products — criticalVendor advisoryCVE-2017-1000355

    Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an XStream: Java crash when trying to instantiate void/Void.

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — criticalNov 3, 2026