Vulnerability · CVE-2017-1000400
The Jenkins 2.73.1 and earlier, 2.83 and earlier remote API at /job/(job-name)/api contained information about upstream and downstream projects.
Published Jan 26, 2018 · catalog updated Jun 17, 2026 · The Jenkins 2.73.1 and
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2017-1000400. EPSS is 0.83%. Act only if a listed version of The Jenkins 2.73.1 and is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (The Jenkins 2.73.1 and).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-117624 · High
- CVE-2026-117623 · Medium
- CVE-2026-117622 · Medium
- CVE-2026-117621 · Medium
- CVE-2026-117620 · High
- Severity
- Medium4.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.83%
- Remediation
- Version ranges on file
- Affected products
- cpe jenkins/jenkins
The Jenkins 2.73.1 and earlier, 2.83 and earlier remote API at /job/(job-name)/api contained information about upstream and downstream projects. This included information about tasks that the current user otherwise has no access to, e.g. due to lack of Item/Read permission. This has been fixed, and the API now only lists upstream and downstream projects that the current user has access to.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe jenkins/jenkins<= 2.73.1
- cpe jenkins/jenkins<= 2.83
How to fix CVE-2017-1000400
Upgrade
CVE-2017-1000400 lists a fix boundary at 2.73.1. Compare the installed build with that boundary before you change production.
Version check
Affected <= 2.73.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2017-1000400. EPSS is 0.83%. Act only if a listed version of The Jenkins 2.73.1 and is installed.
Which versions are affected?
Compare what you have installed with <= 2.73.1, <= 2.83. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-862: Missing Authorization. EPSS 0.83%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jan 26, 2018 · Monitored products — critical
Detected
The Jenkins 2.73.1 and earlier, 2.83 and earlier remote API at /job/(job-name)/api contained information about upstream and downstream projects. This included information about tasks that the current user otherwise has no access to, e.g. due to lack of Item/Read permission. This has been fixed, and the API now only lists upstream and downstream projects that the current user has access to.
Jun 17, 2026 · Monitored products — critical
Updated
The Jenkins 2.73.1 and earlier, 2.83 and earlier remote API at /job/(job-name)/api contained information about upstream and downstream projects. This included information about tasks that the current user otherwise has no access to, e.g. due to lack of Item/Read permission. This has been fixed, and the API now only lists upstream and downstream projects that the current user has access to.
Sources
- CVE.orgVulnerability recordCVE-2017-1000400
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2017-1000400
The Jenkins 2.73.1 and earlier, 2.83 and earlier remote API at /job/(job-name)/api contained information about upstream and downstream projects. This included information about tasks that the current user otherwise has no access to, e.g. due to lack of Item/Read permission. This has been fixed, and the API now only lists upstream and downstream projects that the current user has access to.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026