Vulnerability · CVE-2017-17835
In Apache Airflow 1.8.2 and earlier, a CSRF vulnerability allowed for a remote command injection on a default install of Airflow.
Published Jan 23, 2019 · catalog updated Jun 17, 2026 · In Apache Airflow 1.8.2
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2017-17835. EPSS is 2.04%. Act only if a listed version of In Apache Airflow 1.8.2 is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In Apache Airflow 1.8.2).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-82355 · Medium
- CVE-2026-75158 · Medium
- CVE-2026-86473 · Critical
- CVE-2026-68971 · Medium
- CVE-2026-68970 · Medium
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.04%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/airflow
In Apache Airflow 1.8.2 and earlier, a CSRF vulnerability allowed for a remote command injection on a default install of Airflow.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/airflow<= 1.8.2
How to fix CVE-2017-17835
Upgrade
CVE-2017-17835 lists a fix boundary at 1.8.2. Compare the installed build with that boundary before you change production.
Version check
Affected <= 1.8.2
Advisory
Open the inventory_high record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2017-17835. EPSS is 2.04%. Act only if a listed version of In Apache Airflow 1.8.2 is installed.
Which versions are affected?
Compare what you have installed with <= 1.8.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-352: Cross-Site Request Forgery (CSRF). EPSS 2.04%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jan 23, 2019 · Monitored products — high
Detected
In Apache Airflow 1.8.2 and earlier, a CSRF vulnerability allowed for a remote command injection on a default install of Airflow.
Jun 17, 2026 · Monitored products — high
Updated
In Apache Airflow 1.8.2 and earlier, a CSRF vulnerability allowed for a remote command injection on a default install of Airflow.
Sources
- Monitored products — highVendor advisoryCVE-2017-17835
In Apache Airflow 1.8.2 and earlier, a CSRF vulnerability allowed for a remote command injection on a default install of Airflow.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Monitored products — highNov 2, 2026