Vulnerabilities

Vulnerability · CVE-2017-2601

Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353).

Published May 10, 2018 · catalog updated Jun 17, 2026 · Jenkins before versions 2.44,

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2017-2601. EPSS is 2.03%. Act only if a listed version of Jenkins before versions 2.44, is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Jenkins before versions 2.44,).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
2.03%
Remediation
Version ranges on file
Affected products
cpe jenkins/jenkins

Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe jenkins/jenkins< 2.32.2
  • cpe jenkins/jenkins< 2.44

How to fix CVE-2017-2601

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2017-2601. EPSS is 2.03%. Act only if a listed version of Jenkins before versions 2.44, is installed.

Which versions are affected?

Compare what you have installed with < 2.32.2, < 2.44. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-79: Cross-site Scripting (XSS). EPSS 2.03%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. May 10, 2018 · Monitored products — critical

    Detected

    Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.

  2. Jun 17, 2026 · Monitored products — critical

    Updated

    Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.

Sources

  • CVE.orgVulnerability recordCVE-2017-2601

    Official CVE identifier

    cve.org
  • Monitored products — criticalVendor advisoryCVE-2017-2601

    Jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in parameter names and descriptions (SECURITY-353). Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — criticalNov 3, 2026