Vulnerability · CVE-2017-6359
QNAP QTS before 4.2.4 Build 20170313 allows attackers to gain administrator privileges and execute arbitrary commands via unspecified vectors.
Published Mar 23, 2017 · catalog updated Jun 17, 2026 · QNAP QTS before 4.2.4
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2017-6359 is not in CISA KEV. FIRST estimates a 26.85% chance of exploitation in the next 30 days. Check whether you run QNAP QTS before 4.2.4.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (QNAP QTS before 4.2.4).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-24719 · Medium
- CVE-2026-24717 · Low
- CVE-2026-24716 · Low
- CVE-2026-22893 · High
- CVE-2025-66281 · Medium
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 26.85%
- Remediation
- Version ranges on file
- Affected products
- cpe qnap/qts
QNAP QTS before 4.2.4 Build 20170313 allows attackers to gain administrator privileges and execute arbitrary commands via unspecified vectors.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe qnap/qts<= 4.2.4
How to fix CVE-2017-6359
Upgrade
CVE-2017-6359 lists a fix boundary at 4.2.4. Compare the installed build with that boundary before you change production.
Version check
Affected <= 4.2.4
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2017-6359 is not in CISA KEV. FIRST estimates a 26.85% chance of exploitation in the next 30 days. Check whether you run QNAP QTS before 4.2.4.
Which versions are affected?
Compare what you have installed with <= 4.2.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-78: OS Command Injection. EPSS 26.85%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Mar 23, 2017 · Monitored products — high
Detected
QNAP QTS before 4.2.4 Build 20170313 allows attackers to gain administrator privileges and execute arbitrary commands via unspecified vectors.
Jun 17, 2026 · Monitored products — high
Updated
QNAP QTS before 4.2.4 Build 20170313 allows attackers to gain administrator privileges and execute arbitrary commands via unspecified vectors.
Sources
- CVE.orgVulnerability recordCVE-2017-6359
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2017-6359
QNAP QTS before 4.2.4 Build 20170313 allows attackers to gain administrator privileges and execute arbitrary commands via unspecified vectors.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 6, 2026
- Monitored products — highNov 6, 2026