Vulnerability · CVE-2018-10912
keycloak before version 4.0.0.final is vulnerable to a infinite loop in session replacement.
Published Jul 23, 2018 · catalog updated Jun 17, 2026 · keycloak before version 4.0.0.final
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2018-10912. EPSS is 1.31%. Act only if a listed version of keycloak before version 4.0.0.final is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (keycloak before version 4.0.0.final).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-8419 · Medium
- CVE-2025-5416 · Low
- CVE-2024-7341 · High
- CVE-2024-4629 · Medium
- CVE-2023-6787 · High
- Severity
- Medium4.9
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.31%
- Remediation
- Version ranges on file
- Affected products
- cpe redhat/keycloak · cpe redhat/single sign-on
keycloak before version 4.0.0.final is vulnerable to a infinite loop in session replacement. A Keycloak cluster with multiple nodes could mishandle an expired session replacement and lead to an infinite loop. A malicious authenticated user could use this flaw to achieve Denial of Service on the server.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe redhat/keycloak< 4.0.0
- cpe redhat/single sign-on7.2
How to fix CVE-2018-10912
Upgrade
CVE-2018-10912 lists a fix boundary at 4.0.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 4.0.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2018-10912. EPSS is 1.31%. Act only if a listed version of keycloak before version 4.0.0.final is installed.
Which versions are affected?
Compare what you have installed with redhat/single sign-on 7.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-835: Infinite Loop. EPSS 1.31%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 23, 2018 · Monitored products — high
Detected
keycloak before version 4.0.0.final is vulnerable to a infinite loop in session replacement. A Keycloak cluster with multiple nodes could mishandle an expired session replacement and lead to an infinite loop. A malicious authenticated user could use this flaw to achieve Denial of Service on the server.
Jun 17, 2026 · Monitored products — high
Updated
keycloak before version 4.0.0.final is vulnerable to a infinite loop in session replacement. A Keycloak cluster with multiple nodes could mishandle an expired session replacement and lead to an infinite loop. A malicious authenticated user could use this flaw to achieve Denial of Service on the server.
Sources
- CVE.orgVulnerability recordCVE-2018-10912
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2018-10912
keycloak before version 4.0.0.final is vulnerable to a infinite loop in session replacement. A Keycloak cluster with multiple nodes could mishandle an expired session replacement and lead to an infinite loop. A malicious authenticated user could use this flaw to achieve Denial of Service on the server.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 3, 2026