Vulnerability · CVE-2018-12099
Grafana before 5.2.0-beta1 has XSS vulnerabilities in dashboard links.
Published Jun 11, 2018 · catalog updated Jun 17, 2026 · Grafana before 5.2.0-beta1 has
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2018-12099. EPSS is 2.11%. Act only if a listed version of Grafana before 5.2.0-beta1 has is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Grafana before 5.2.0-beta1 has).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-14199 · High
- CVE-2026-33382 · High
- CVE-2026-8595 · Medium
- CVE-2026-8609 · High
- CVE-2026-28378 · Low
- Severity
- Medium6.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.11%
- Remediation
- Version ranges on file
- Affected products
- cpe grafana/grafana · cpe netapp/active iq performance analytics services · cpe netapp/storagegrid webscale nas bridge
Grafana before 5.2.0-beta1 has XSS vulnerabilities in dashboard links.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe grafana/grafana<= 5.1.3
- cpe netapp/active iq performance analytics servicesversion unspecified
- cpe netapp/storagegrid webscale nas bridgeversion unspecified
How to fix CVE-2018-12099
Upgrade
CVE-2018-12099 lists a fix boundary at 5.1.3. Compare the installed build with that boundary before you change production.
Version check
Affected <= 5.1.3
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2018-12099. EPSS is 2.11%. Act only if a listed version of Grafana before 5.2.0-beta1 has is installed.
Which versions are affected?
Compare what you have installed with <= 5.1.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-79: Cross-site Scripting (XSS). EPSS 2.11%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jun 11, 2018 · Monitored products — high
Detected
Grafana before 5.2.0-beta1 has XSS vulnerabilities in dashboard links.
Jun 17, 2026 · Monitored products — high
Updated
Grafana before 5.2.0-beta1 has XSS vulnerabilities in dashboard links.
Sources
- CVE.orgVulnerability recordCVE-2018-12099
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2018-12099
Grafana before 5.2.0-beta1 has XSS vulnerabilities in dashboard links.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 2, 2026