Vulnerability · CVE-2018-16854
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier.
Published Nov 26, 2018 · catalog updated Jun 17, 2026 · A flaw was found
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2018-16854. EPSS is 2.33%. Act only if a listed version of A flaw was found is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (A flaw was found).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-102588 · Medium
- CVE-2026-102587 · Low
- CVE-2026-102586 · Medium
- CVE-2026-102585 · Medium
- CVE-2026-102584 · Medium
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.33%
- Remediation
- Version ranges on file
- Affected products
- cpe moodle/moodle
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe moodle/moodle< 3.1.15
- cpe moodle/moodle< 3.3.9
- cpe moodle/moodle< 3.4.6
- cpe moodle/moodle< 3.5.3
- cpe moodle/moodle<= 3.0.10
How to fix CVE-2018-16854
Upgrade
CVE-2018-16854 lists a fix boundary at 3.1.15. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.1.15
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2018-16854. EPSS is 2.33%. Act only if a listed version of A flaw was found is installed.
Which versions are affected?
Compare what you have installed with < 3.1.15, < 3.3.9, < 3.4.6, < 3.5.3, <= 3.0.10. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-352: Cross-Site Request Forgery (CSRF). EPSS 2.33%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Nov 26, 2018 · Monitored products — high
Detected
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Jun 17, 2026 · Monitored products — high
Updated
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Sources
- CVE.orgVulnerability recordCVE-2018-16854
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2018-16854
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 4, 2026