Vulnerability · CVE-2018-16876
ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.
Published Jan 3, 2019 · catalog updated Jun 17, 2026 · ansible before versions 2.5.14,
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2018-16876. EPSS is 2.48%. Act only if a listed version of ansible before versions 2.5.14, is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (ansible before versions 2.5.14,).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2024-0690 · Medium
- CVE-2023-5764 · High
- CVE-2022-3697 · High
- CVE-2021-20180 · Medium
- CVE-2021-20178 · Medium
- Severity
- Medium5.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.48%
- Remediation
- Version ranges on file
- Affected products
- cpe debian/debian linux · cpe redhat/ansible · cpe redhat/ansible engine
ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe debian/debian linux9.0
- cpe redhat/ansible< 2.5.14
- cpe redhat/ansible< 2.6.11
- cpe redhat/ansible< 2.7.5
- cpe redhat/ansible engine2.0
- cpe redhat/ansible engine2.5
How to fix CVE-2018-16876
Upgrade
CVE-2018-16876 lists a fix boundary at 2.5.14. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.5.14
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2018-16876. EPSS is 2.48%. Act only if a listed version of ansible before versions 2.5.14, is installed.
Which versions are affected?
Compare what you have installed with debian/debian linux 9.0; redhat/ansible engine 2.0; redhat/ansible engine 2.5. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-200: Exposure of Sensitive Information. EPSS 2.48%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jan 3, 2019 · Monitored products — high
Detected
ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.
Jun 17, 2026 · Monitored products — high
Updated
ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.
Sources
- CVE.orgVulnerability recordCVE-2018-16876
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2018-16876
ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 2, 2026