Vulnerabilities

Vulnerability · CVE-2019-14856

ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None

Published Nov 26, 2019 · catalog updated Jun 17, 2026 · ansible before versions 2.8.6,

Last checked Nov 5, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2019-14856. EPSS is 1.66%. Act only if a listed version of ansible before versions 2.8.6, is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (ansible before versions 2.8.6,).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.66%
Remediation
Version ranges on file
Affected products
cpe opensuse/backports sle · cpe opensuse/leap · cpe redhat/ansible · cpe redhat/openstack

ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe opensuse/backports sle15.0
  • cpe opensuse/leap15.1
  • cpe redhat/ansible< 2.6.20
  • cpe redhat/ansible< 2.7.14
  • cpe redhat/ansible< 2.8.6
  • cpe redhat/openstack13

How to fix CVE-2019-14856

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2019-14856. EPSS is 1.66%. Act only if a listed version of ansible before versions 2.8.6, is installed.

Which versions are affected?

Compare what you have installed with opensuse/backports sle 15.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-287: Improper Authentication. EPSS 1.66%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 26, 2019 · Monitored products — high

    Detected

    ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None

  2. Jun 17, 2026 · Monitored products — high

    Updated

    ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None

Sources

References

Freshness

Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — highNov 2, 2026