Vulnerability · CVE-2019-3394
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting.
Published Aug 29, 2019 · catalog updated Jun 17, 2026 · There was a local
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2019-3394 is not in CISA KEV. FIRST estimates a 11.02% chance of exploitation in the next 30 days. Check whether you run There was a local.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (There was a local).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2020-4027 · Medium
- CVE-2019-20406 · High
- CVE-2019-15006 · Medium
- CVE-2019-3395 · Critical
- CVE-2018-13389 · Medium
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 11.02%
- Remediation
- Version ranges on file
- Affected products
- cpe atlassian/confluence · cpe atlassian/confluence server
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under /confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sensitive information such as LDAP credentials. The LDAP credential will be potentially leaked only if the Confluence server is configured to use LDAP as user repository. All versions of Confluence Server from 6.1.0 before 6.6.16 (the fixed version for 6.6.x), from 6.7.0 before 6.13.7 (the fixed version for 6.13.x), and from 6.14.0 before 6.15.8 (the fixed version for 6.15.x) are affected by this vulnerability.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe atlassian/confluence< 6.13.7
- cpe atlassian/confluence< 6.6.16
- cpe atlassian/confluence server< 6.15.8
How to fix CVE-2019-3394
Upgrade
CVE-2019-3394 lists a fix boundary at 6.13.7. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.13.7
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2019-3394 is not in CISA KEV. FIRST estimates a 11.02% chance of exploitation in the next 30 days. Check whether you run There was a local.
Which versions are affected?
Compare what you have installed with atlassian/confluence server < 6.15.8. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-22: Path Traversal. EPSS 11.02%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Aug 29, 2019 · Monitored products — critical
Detected
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under /confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sens
Jun 17, 2026 · Monitored products — critical
Updated
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under /confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sens
Sources
- CVE.orgVulnerability recordCVE-2019-3394
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2019-3394
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under /confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sens
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026