Vulnerability · CVE-2020-14321
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
Published Aug 16, 2022 · catalog updated Jun 17, 2026 · In Moodle before 3.9.1,
Last checked Nov 7, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2020-14321 is not in CISA KEV. FIRST estimates a 15.99% chance of exploitation in the next 30 days. Check whether you run In Moodle before 3.9.1,.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In Moodle before 3.9.1,).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-102588 · Medium
- CVE-2026-102587 · Low
- CVE-2026-102586 · Medium
- CVE-2026-102585 · Medium
- CVE-2026-102584 · Medium
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 15.99%
- Remediation
- Version ranges on file
- Affected products
- cpe moodle/moodle
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe moodle/moodle3.9.0
- cpe moodle/moodle< 3.5.13
- cpe moodle/moodle< 3.7.7
- cpe moodle/moodle< 3.8.4
How to fix CVE-2020-14321
Upgrade
CVE-2020-14321 lists a fix boundary at 3.5.13. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.5.13
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2020-14321 is not in CISA KEV. FIRST estimates a 15.99% chance of exploitation in the next 30 days. Check whether you run In Moodle before 3.9.1,.
Which versions are affected?
Compare what you have installed with 3.9.0, < 3.5.13, < 3.7.7, < 3.8.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-863: Incorrect Authorization. EPSS 15.99%. There is no CISA KEV listing. A public exploit reference is linked in Sources. That is not the same as confirmed exploitation. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Aug 16, 2022 · Monitored products — high
Detected
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
Jun 17, 2026 · Monitored products — high
Updated
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
Sources
- CVE.orgVulnerability recordCVE-2020-14321
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2020-14321
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
nvd.nist.gov - Metasploit ModulesPublic exploit moduleexploit_multi/http/moodle_teacher_enrollment_priv_esc_to_rce
Public module reference (good). Module source is not copied into this catalog.
rapid7.com
References
Freshness
Last verified in this catalog Nov 7, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Metasploit ModulesNov 7, 2026
- CVE.orgNov 4, 2026
- Monitored products — highNov 4, 2026