Vulnerability · CVE-2020-14322
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, yui_combo needed to limit the amount of files it can load to help mitigate the risk of denial of service.
Published Aug 16, 2022 · catalog updated Jun 17, 2026 · In Moodle before 3.9.1,
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2020-14322. EPSS is 0.95%. Act only if a listed version of In Moodle before 3.9.1, is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In Moodle before 3.9.1,).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-102588 · Medium
- CVE-2026-102587 · Low
- CVE-2026-102586 · Medium
- CVE-2026-102585 · Medium
- CVE-2026-102584 · Medium
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.95%
- Remediation
- Version ranges on file
- Affected products
- cpe moodle/moodle
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, yui_combo needed to limit the amount of files it can load to help mitigate the risk of denial of service.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe moodle/moodle3.9.0
- cpe moodle/moodle< 3.5.13
- cpe moodle/moodle< 3.7.7
- cpe moodle/moodle< 3.8.4
How to fix CVE-2020-14322
Upgrade
CVE-2020-14322 lists a fix boundary at 3.5.13. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.5.13
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2020-14322. EPSS is 0.95%. Act only if a listed version of In Moodle before 3.9.1, is installed.
Which versions are affected?
Compare what you have installed with 3.9.0, < 3.5.13, < 3.7.7, < 3.8.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-770: Allocation of Resources Without Limits or Throttling. EPSS 0.95%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Aug 16, 2022 · Monitored products — high
Detected
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, yui_combo needed to limit the amount of files it can load to help mitigate the risk of denial of service.
Jun 17, 2026 · Monitored products — high
Updated
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, yui_combo needed to limit the amount of files it can load to help mitigate the risk of denial of service.
Sources
- CVE.orgVulnerability recordCVE-2020-14322
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2020-14322
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, yui_combo needed to limit the amount of files it can load to help mitigate the risk of denial of service.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 4, 2026