Security fix · CVE-2020-15079
In PrestaShop from version 1.5.0.0 and before version 1.7.6.6, there is improper access control in Carrier page, Module Manager and Module Positions.
Published Jul 2, 2020 · catalog updated Jun 17, 2026 · In PrestaShop from version
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2020-15079. EPSS is 0.58%. Act only if a listed version of In PrestaShop from version is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In PrestaShop from version).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-33673 · High
- CVE-2026-33674 · Medium
- CVE-2025-51586 · Medium
- CVE-2025-25692 · Medium
- CVE-2025-25691 · Medium
- Severity
- Medium5.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.58%
- Remediation
- Version ranges on file
- Affected products
- cpe prestashop/prestashop
In PrestaShop from version 1.5.0.0 and before version 1.7.6.6, there is improper access control in Carrier page, Module Manager and Module Positions. The problem is fixed in version 1.7.6.6
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe prestashop/prestashop> 1.5.0.0, < 1.7.6.6
How to fix CVE-2020-15079
Upgrade
CVE-2020-15079 lists a fix boundary at 1.7.6.6. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.7.6.6
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2020-15079. EPSS is 0.58%. Act only if a listed version of In PrestaShop from version is installed.
Which versions are affected?
Compare what you have installed with > 1.5.0.0, < 1.7.6.6. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-284: Improper Access Control. EPSS 0.58%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 2, 2020 · Monitored products — high
Detected
In PrestaShop from version 1.5.0.0 and before version 1.7.6.6, there is improper access control in Carrier page, Module Manager and Module Positions. The problem is fixed in version 1.7.6.6
Jun 17, 2026 · Monitored products — high
Updated
In PrestaShop from version 1.5.0.0 and before version 1.7.6.6, there is improper access control in Carrier page, Module Manager and Module Positions. The problem is fixed in version 1.7.6.6
Sources
- CVE.orgVulnerability recordCVE-2020-15079
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2020-15079
In PrestaShop from version 1.5.0.0 and before version 1.7.6.6, there is improper access control in Carrier page, Module Manager and Module Positions. The problem is fixed in version 1.7.6.6
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 3, 2026