Vulnerabilities

Vulnerability · CVE-2020-1756

In Moodle before 3.8.2, 3.7.5, 3.6.9 and 3.5.11, insufficient input escaping was applied to the PHP unit webrunner admin tool.

Published Aug 16, 2022 · catalog updated Jun 17, 2026 · In Moodle before 3.8.2,

Last checked Nov 7, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2020-1756. EPSS is 1.03%. Act only if a listed version of In Moodle before 3.8.2, is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (In Moodle before 3.8.2,).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.2
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.03%
Remediation
Version ranges on file
Affected products
cpe moodle/moodle

In Moodle before 3.8.2, 3.7.5, 3.6.9 and 3.5.11, insufficient input escaping was applied to the PHP unit webrunner admin tool.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe moodle/moodle< 3.5.11
  • cpe moodle/moodle< 3.6.9
  • cpe moodle/moodle< 3.7.5
  • cpe moodle/moodle< 3.8.2

How to fix CVE-2020-1756

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2020-1756. EPSS is 1.03%. Act only if a listed version of In Moodle before 3.8.2, is installed.

Which versions are affected?

Compare what you have installed with < 3.5.11, < 3.6.9, < 3.7.5, < 3.8.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-20: Improper Input Validation. EPSS 1.03%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Aug 16, 2022 · Monitored products — high

    Detected

    In Moodle before 3.8.2, 3.7.5, 3.6.9 and 3.5.11, insufficient input escaping was applied to the PHP unit webrunner admin tool.

  2. Jun 17, 2026 · Monitored products — high

    Updated

    In Moodle before 3.8.2, 3.7.5, 3.6.9 and 3.5.11, insufficient input escaping was applied to the PHP unit webrunner admin tool.

Sources

References

Freshness

Last verified in this catalog Nov 7, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — highNov 4, 2026