Vulnerability · CVE-2020-2104
Jenkins 2.218 and earlier, LTS 2.204.1 and earlier allowed users with Overall/Read access to view a JVM memory usage chart.
Published Jan 29, 2020 · catalog updated Jun 17, 2026 · Jenkins 2.218 and earlier,
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2020-2104. EPSS is 1.07%. Act only if a listed version of Jenkins 2.218 and earlier, is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Jenkins 2.218 and earlier,).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-117624 · High
- CVE-2026-117623 · Medium
- CVE-2026-117622 · Medium
- CVE-2026-117621 · Medium
- CVE-2026-117620 · High
- Severity
- Medium4.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.07%
- Remediation
- Version ranges on file
- Affected products
- cpe jenkins/jenkins
Jenkins 2.218 and earlier, LTS 2.204.1 and earlier allowed users with Overall/Read access to view a JVM memory usage chart.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe jenkins/jenkins<= 2.204.1
- cpe jenkins/jenkins<= 2.218
How to fix CVE-2020-2104
Upgrade
CVE-2020-2104 lists a fix boundary at 2.204.1. Compare the installed build with that boundary before you change production.
Version check
Affected <= 2.204.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2020-2104. EPSS is 1.07%. Act only if a listed version of Jenkins 2.218 and earlier, is installed.
Which versions are affected?
Compare what you have installed with <= 2.204.1, <= 2.218. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-863: Incorrect Authorization. EPSS 1.07%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jan 29, 2020 · Monitored products — critical
Detected
Jenkins 2.218 and earlier, LTS 2.204.1 and earlier allowed users with Overall/Read access to view a JVM memory usage chart.
Jun 17, 2026 · Monitored products — critical
Updated
Jenkins 2.218 and earlier, LTS 2.204.1 and earlier allowed users with Overall/Read access to view a JVM memory usage chart.
Sources
- CVE.orgVulnerability recordCVE-2020-2104
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2020-2104
Jenkins 2.218 and earlier, LTS 2.204.1 and earlier allowed users with Overall/Read access to view a JVM memory usage chart.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026