Vulnerabilities

Security fix · CVE-2020-25698

Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course.

Published Nov 19, 2020 · catalog updated Jun 17, 2026 · Users' enrollment capabilities were

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2020-25698. EPSS is 1.92%. Act only if a listed version of Users' enrollment capabilities were is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Users' enrollment capabilities were).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.92%
Remediation
Version ranges on file
Affected products
cpe fedoraproject/fedora · cpe moodle/moodle

Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe fedoraproject/fedora32
  • cpe fedoraproject/fedora33
  • cpe moodle/moodle>= 3.5.0, <= 3.5.14
  • cpe moodle/moodle>= 3.7.0, <= 3.7.8
  • cpe moodle/moodle>= 3.8.0, <= 3.8.5
  • cpe moodle/moodle>= 3.9.0, <= 3.9.2

How to fix CVE-2020-25698

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2020-25698. EPSS is 1.92%. Act only if a listed version of Users' enrollment capabilities were is installed.

Which versions are affected?

Compare what you have installed with 32, 33, >= 3.5.0, <= 3.5.14, >= 3.7.0, <= 3.7.8, >= 3.8.0, <= 3.8.5, >= 3.9.0, <= 3.9.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-284: Improper Access Control. EPSS 1.92%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 19, 2020 · Monitored products — high

    Detected

    Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

  2. Jun 17, 2026 · Monitored products — high

    Updated

    Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Sources

  • CVE.orgVulnerability recordCVE-2020-25698

    Official CVE identifier

    cve.org
  • Monitored products — highVendor advisoryCVE-2020-25698

    Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — highNov 4, 2026