Vulnerabilities

Security incident · CVE-2020-37094

EspoCRM 5.7.0 prior to 5.9.0 contains an authentication token reuse vulnerability that allows authenticated attackers to bypass two-factor authentication by exploiting token-to-pas

Published Feb 3, 2026 · catalog updated Jul 15, 2026 · EspoCRM 5.7.0 prior to

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2020-37094. EPSS is 0.53%. Act only if a listed version of EspoCRM 5.7.0 prior to is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (EspoCRM 5.7.0 prior to).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High8.6
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.53%
Remediation
Version ranges on file
Affected products
vendor espocrm espocrm 5.7.0 <5.9.0

EspoCRM 5.7.0 prior to 5.9.0 contains an authentication token reuse vulnerability that allows authenticated attackers to bypass two-factor authentication by exploiting token-to-password-hash mapping in application/Espo/Core/Utils/Authentication/Espo.php. Attackers can obtain an authentication token for a controlled account and replay it against any victim account sharing the same password, since tokens are bound to password hashes rather than unique per-user values, bypassing the victim's 2FA protections.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor espocrm espocrm 5.7.0 <5.9.05.7.0 <5.9.0

How to fix CVE-2020-37094

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2020-37094. EPSS is 0.53%. Act only if a listed version of EspoCRM 5.7.0 prior to is installed.

Which versions are affected?

Compare what you have installed with espocrm espocrm 5.7.0 <5.9.0 5.7.0 <5.9.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.53%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Feb 3, 2026 · EUVD

    Detected

    EspoCRM 5.7.0 prior to 5.9.0 contains an authentication token reuse vulnerability that allows authenticated attackers to bypass two-factor authentication by exploiting token-to-password-hash mapping in application/Espo/Core/Utils/Authentication/Espo.php. Attackers can obtain an authentication token for a controlled account and replay it against any victim account sharing the same password, since t

  2. Jul 15, 2026 · EUVD

    Updated

    EspoCRM 5.7.0 prior to 5.9.0 contains an authentication token reuse vulnerability that allows authenticated attackers to bypass two-factor authentication by exploiting token-to-password-hash mapping in application/Espo/Core/Utils/Authentication/Espo.php. Attackers can obtain an authentication token for a controlled account and replay it against any victim account sharing the same password, since t

Sources

  • FIRST EPSSExploitation probabilityCVE-2020-37094

    30-day exploitation probability 0.53%

    first.org
  • EUVDVulnerability recordEUVD-2020-31008

    EspoCRM 5.7.0 prior to 5.9.0 contains an authentication token reuse vulnerability that allows authenticated attackers to bypass two-factor authentication by exploiting token-to-password-hash mapping in application/Espo/Core/Utils/Authentication/Espo.php. Attackers can obtain an a

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 2, 2026
  • EUVDNov 2, 2026