Vulnerability · CVE-2020-8621
In BIND 9.14.0 -> 9.16.5, 9.17.0 -> 9.17.3, If a server is configured with both QNAME minimization and 'forward first' then an attacker who can send queries to it may be able to tr
Published Aug 21, 2020 · catalog updated Oct 26, 2026 · In BIND 9.14.0 ->
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2020-8621. EPSS is 3.06%. Act only if a listed version of In BIND 9.14.0 -> is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In BIND 9.14.0 ->).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 3.06%
- Remediation
- Advisory link
- Affected products
- Alpine:v3.10 bind · Alpine:v3.11 bind · Alpine:v3.12 bind · Alpine:v3.13 bind · Alpine:v3.14 bind · Alpine:v3.15 bind
In BIND 9.14.0 -> 9.16.5, 9.17.0 -> 9.17.3, If a server is configured with both QNAME minimization and 'forward first' then an attacker who can send queries to it may be able to trigger the condition that will cause the server to crash. Servers that 'forward only' are not affected.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Alpine:v3.10 bind9.14.0 → 9.16.6-r0
- Alpine:v3.11 bind9.14.0 → 9.16.6-r0
- Alpine:v3.12 bind9.14.0 → 9.16.6-r0
- Alpine:v3.13 bind9.14.0 → 9.16.6-r0
- Alpine:v3.14 bind9.14.0 → 9.16.6-r0
- Alpine:v3.15 bind9.14.0 → 9.16.6-r0
- Alpine:v3.16 bind9.14.0 → 9.16.6-r0
- Alpine:v3.17 bind9.14.0 → 9.16.6-r0
- Alpine:v3.18 bind9.14.0 → 9.16.6-r0
- Alpine:v3.19 bind9.14.0 → 9.16.6-r0
- Alpine:v3.20 bind9.14.0 → 9.16.6-r0
- Alpine:v3.21 bind9.14.0 → 9.16.6-r0
How to fix CVE-2020-8621
Upgrade
CVE-2020-8621 lists a fix boundary at 9.16.6-r0. Compare the installed build with that boundary before you change production.
Version check
Seen in 9.14.0 → 9.16.6-r0 · 5 other packages on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2020-8621. EPSS is 3.06%. Act only if a listed version of In BIND 9.14.0 -> is installed.
Which versions are affected?
Compare what you have installed with 9.14.0 → 9.16.6-r0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 3.06%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Aug 21, 2020 · Trivy Vulnerability DB
Detected
In BIND 9.14.0 -> 9.16.5, 9.17.0 -> 9.17.3, If a server is configured with both QNAME minimization and 'forward first' then an attacker who can send queries to it may be able to trigger the condition that will cause the server to crash. Servers that 'forward only' are not affected.
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
bind fixed in 9.16.6-r0; bind fixed in 9.16.6-r0; bind fixed in 9.16.6-r0; bind fixed in 9.16.6-r0
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
bind fixed in 9.16.6-r0
Oct 26, 2026 · Trivy Vulnerability DB
Updated
In BIND 9.14.0 -> 9.16.5, 9.17.0 -> 9.17.3, If a server is configured with both QNAME minimization and 'forward first' then an attacker who can send queries to it may be able to trigger the condition that will cause the server to crash. Servers that 'forward only' are not affected.
Sources
- CVE.orgVulnerability recordCVE-2020-8621
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2020-8621
30-day exploitation probability 3.06%
first.org - Trivy Vulnerability DBPackage advisoryALPINE-CVE-2020-8621
In BIND 9.14.0 -> 9.16.5, 9.17.0 -> 9.17.3, If a server is configured with both QNAME minimization and 'forward first' then an attacker who can send queries to it may be able to trigger the condition that will cause the server to crash. Servers that 'forward only' are not affecte
osv.dev
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- CVE.orgOct 26, 2026
- Trivy Vulnerability DBOct 26, 2026