Vulnerability · CVE-2020-8625
BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features.
Published Feb 17, 2021 · catalog updated Oct 26, 2026 · BIND servers are vulnerable
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2020-8625 is not in CISA KEV. FIRST estimates a 64.16% chance of exploitation in the next 30 days. Check whether you run BIND servers are vulnerable.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (BIND servers are vulnerable).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 64.16%
- Remediation
- Advisory link
- Affected products
- Alpine:v3.10 bind · Alpine:v3.11 bind · Alpine:v3.12 bind · Alpine:v3.13 bind · Alpine:v3.14 bind · Alpine:v3.15 bind
BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features. In a configuration which uses BIND's default settings the vulnerable code path is not exposed, but a server can be rendered vulnerable by explicitly setting valid values for the tkey-gssapi-keytab or tkey-gssapi-credentialconfiguration options. Although the default configuration is not vulnerable, GSS-TSIG is frequently used in networks where BIND is integrated with Samba, as well as in mixed-server environments that combine BIND servers with Active Directory domain controllers. The most likely outcome of a successful exploitation of the vulnerability is a crash of the named process. However, remote code execution, while unproven, is theoretically possible. Affects: BIND 9.5.0 -> 9.11.27, 9.12.0 -> 9.16.11, and versions BIND 9.11.3-S1 -> 9.11.27-S1 and 9.16.8-S1 -> 9.16.11-S1 of BIND Supported Preview Edition. Also release versions 9.17.0 -> 9.17.1 of the BIND 9.17 development branch
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Alpine:v3.10 bind9.5.0 → 9.16.11-r2
- Alpine:v3.11 bind9.5.0 → 9.16.11-r2
- Alpine:v3.12 bind9.5.0 → 9.16.11-r2
- Alpine:v3.13 bind9.5.0 → 9.16.11-r2
- Alpine:v3.14 bind9.5.0 → 9.16.11-r2
- Alpine:v3.15 bind9.5.0 → 9.16.11-r2
- Alpine:v3.16 bind9.5.0 → 9.16.11-r2
- Alpine:v3.17 bind9.5.0 → 9.16.11-r2
- Alpine:v3.18 bind9.5.0 → 9.16.11-r2
- Alpine:v3.19 bind9.5.0 → 9.16.11-r2
- Alpine:v3.20 bind9.5.0 → 9.16.11-r2
- Alpine:v3.21 bind9.5.0 → 9.16.11-r2
How to fix CVE-2020-8625
Upgrade
CVE-2020-8625 lists a fix boundary at 9.16.11-r2. Compare the installed build with that boundary before you change production.
Version check
Seen in 9.5.0 → 9.16.11-r2 · 5 other packages on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2020-8625 is not in CISA KEV. FIRST estimates a 64.16% chance of exploitation in the next 30 days. Check whether you run BIND servers are vulnerable.
Which versions are affected?
Compare what you have installed with 9.5.0 → 9.16.11-r2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 64.16%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Feb 17, 2021 · Trivy Vulnerability DB
Detected
BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features. In a configuration which uses BIND's default settings the vulnerable code path is not exposed, but a server can be rendered vulnerable by explicitly setting valid values for the tkey-gssapi-keytab or tkey-gssapi-credentialconfiguration options. Although the default configuration is not
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
bind fixed in 9.16.11-r2; bind fixed in 9.16.11-r2; bind fixed in 9.16.11-r2; bind fixed in 9.16.11-r2
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
bind fixed in 9.16.11-r2
Oct 26, 2026 · Trivy Vulnerability DB
Updated
BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features. In a configuration which uses BIND's default settings the vulnerable code path is not exposed, but a server can be rendered vulnerable by explicitly setting valid values for the tkey-gssapi-keytab or tkey-gssapi-credentialconfiguration options. Although the default configuration is not
Sources
- CVE.orgVulnerability recordCVE-2020-8625
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2020-8625
30-day exploitation probability 64.16%
first.org - OpenSSF OSV / OSV ScannerPackage advisoryALPINE-CVE-2020-8625osv.dev
- Trivy Vulnerability DBPackage advisoryALPINE-CVE-2020-8625
BIND servers are vulnerable if they are running an affected version and are configured to use GSS-TSIG features. In a configuration which uses BIND's default settings the vulnerable code path is not exposed, but a server can be rendered vulnerable by explicitly setting valid valu
osv.dev
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 4, 2026
- OpenSSF OSV / OSV ScannerOct 26, 2026
- CVE.orgOct 26, 2026
- Trivy Vulnerability DBOct 26, 2026