Vulnerability · CVE-2020-8927
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger
Published Sep 15, 2020 · catalog updated Oct 26, 2026 · A buffer overflow exists
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2020-8927. EPSS is 3.22%. Act only if a listed version of A buffer overflow exists is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (A buffer overflow exists).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 3.22%
- Remediation
- Advisory link
- Affected products
- Alpine:v3.12 brotli · Alpine:v3.13 brotli · Alpine:v3.14 brotli · Alpine:v3.15 brotli · Alpine:v3.16 brotli · Alpine:v3.17 brotli
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Alpine:v3.12 brotli0 → 1.0.9-r0
- Alpine:v3.13 brotli0 → 1.0.9-r0
- Alpine:v3.14 brotli0 → 1.0.9-r0
- Alpine:v3.15 brotli0 → 1.0.9-r0
- Alpine:v3.16 brotli0 → 1.0.9-r0
- Alpine:v3.17 brotli0 → 1.0.9-r0
- Alpine:v3.18 brotli0 → 1.0.9-r0
- Alpine:v3.19 brotli0 → 1.0.9-r0
- Alpine:v3.20 brotli0 → 1.0.9-r0
- Alpine:v3.21 brotli0 → 1.0.9-r0
- Alpine:v3.22 brotli0 → 1.0.9-r0
- Alpine:v3.23 brotli0 → 1.0.9-r0
How to fix CVE-2020-8927
Upgrade
CVE-2020-8927 lists a fix boundary at 1.0.9-r0. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1.0.9-r0 · 5 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2020-8927. EPSS is 3.22%. Act only if a listed version of A buffer overflow exists is installed.
Which versions are affected?
Compare what you have installed with 0 → 1.0.9-r0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 3.22%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Sep 15, 2020 · Trivy Vulnerability DB
Detected
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to th
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
brotli fixed in 1.0.9-r0; brotli fixed in 1.0.9-r0; brotli fixed in 1.0.9-r0; brotli fixed in 1.0.9-r0
Oct 26, 2026 · Trivy Vulnerability DB
Fix available
brotli fixed in 1.0.9-r0
Oct 26, 2026 · Trivy Vulnerability DB
Updated
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to th
Sources
- CVE.orgVulnerability recordCVE-2020-8927
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2020-8927
30-day exploitation probability 3.22%
first.org - OpenSSF OSV / OSV ScannerPackage advisoryALPINE-CVE-2020-8927osv.dev
- Trivy Vulnerability DBPackage advisoryALPINE-CVE-2020-8927
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to upda
osv.dev
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 4, 2026
- OpenSSF OSV / OSV ScannerOct 26, 2026
- CVE.orgOct 26, 2026
- Trivy Vulnerability DBOct 26, 2026