Vulnerabilities

Vulnerability · CVE-2021-28359

CVE-2021-28359 is listed by The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit..

Published May 2, 2021 · catalog updated Jun 17, 2026 · the affected product

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Check this week

CVE-2021-28359 is not in CISA KEV. FIRST estimates a 14.39% chance of exploitation in the next 30 days. Check whether you run the affected product.

Gaps on this record

  • No plain product name is stored. The page cannot tell you which product to check.
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
14.39%
Remediation
Version ranges on file
Affected products
cpe apache/airflow

CVE-2021-28359 is listed by The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit..

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe apache/airflow< 1.10.15
  • cpe apache/airflow< 2.0.2

How to fix CVE-2021-28359

  • Upgrade

    CVE-2021-28359 lists a fix boundary at 1.10.15. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 1.10.15

  • Advisory

    Open the inventory_high record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

CVE-2021-28359 is not in CISA KEV. FIRST estimates a 14.39% chance of exploitation in the next 30 days. Check whether you run the affected product.

Which versions are affected?

Compare what you have installed with < 1.10.15, < 2.0.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-79: Cross-site Scripting (XSS). EPSS 14.39%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. May 2, 2021 · Monitored products — high

    Detected

    CVE-2021-28359 is listed by The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit..

  2. Jun 17, 2026 · Monitored products — high

    Updated

    CVE-2021-28359 is listed by The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit..

Sources

  • Monitored products — highVendor advisoryCVE-2021-28359

    The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions <1.10.15 in 1.x series and affects 2.0.0 and 2.0.1 and 2.x series. This is the same as CVE-2020-13944 & CVE-2020-17515 but the implemented fix did not fix the issue completely. Update to Airflow 1.10.15 or 2.0.2. Please also update your Python version to

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • Monitored products — highNov 2, 2026