Vulnerability · CVE-2021-36976
libarchive 3.4.1 through 3.5.1 has a use-after-free in copy_string (called from do_uncompress_block and process_block).
Published Jul 20, 2021 · catalog updated Nov 2, 2026 · libarchive 3.4.1 through 3.5.1
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2021-36976. EPSS is 2.84%. Act only if a listed version of libarchive 3.4.1 through 3.5.1 is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (libarchive 3.4.1 through 3.5.1).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-5745 · Medium
- CVE-2026-5121 · High
- CVE-2026-4426 · Medium
- CVE-2026-4424 · High
- CVE-2025-5914 · High
- Severity
- Medium6.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.84%
- Remediation
- Version ranges on file
- Affected products
- cpe apple/ipados · cpe apple/iphone os · cpe apple/macos · cpe apple/watchos · cpe libarchive/libarchive · cpe splunk/universal forwarder
libarchive 3.4.1 through 3.5.1 has a use-after-free in copy_string (called from do_uncompress_block and process_block).
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apple/ipados< 15.4
- cpe apple/iphone os< 15.4
- cpe apple/macos< 12.3
- cpe apple/watchos< 8.5
- cpe libarchive/libarchive>= 3.4.1, <= 3.5.2
- cpe splunk/universal forwarder9.1.0
- cpe splunk/universal forwarder< 8.2.12
- cpe splunk/universal forwarder< 9.0.6
How to fix CVE-2021-36976
Upgrade
CVE-2021-36976 lists a fix boundary at 15.4. Compare the installed build with that boundary before you change production.
Version check
Affected < 15.4
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2021-36976. EPSS is 2.84%. Act only if a listed version of libarchive 3.4.1 through 3.5.1 is installed.
Which versions are affected?
Compare what you have installed with apple/iphone os < 15.4; splunk/universal forwarder 9.1.0; splunk/universal forwarder < 8.2.12; splunk/universal forwarder < 9.0.6. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-416: Use After Free. EPSS 2.84%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 20, 2021 · NIST NVD
Detected
libarchive 3.4.1 through 3.5.1 has a use-after-free in copy_string (called from do_uncompress_block and process_block).
Nov 2, 2026 · NIST NVD
Updated
libarchive 3.4.1 through 3.5.1 has a use-after-free in copy_string (called from do_uncompress_block and process_block).
Sources
- CVE.orgVulnerability recordCVE-2021-36976
Official CVE identifier
cve.org - NIST NVDVulnerability recordCVE-2021-36976
libarchive 3.4.1 through 3.5.1 has a use-after-free in copy_string (called from do_uncompress_block and process_block).
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- NIST NVDNov 3, 2026