Vulnerabilities

Vulnerability · CVE-2021-38593

Qt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath (called from QRasterPaintEngine::fill and QPaintEngineEx::stroke).

Published Aug 12, 2021 · catalog updated Nov 2, 2026 · Qt 5.x before 5.15.6

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2021-38593. EPSS is 3.00%. Act only if a listed version of Qt 5.x before 5.15.6 is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Qt 5.x before 5.15.6).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
3.00%
Remediation
Version ranges on file
Affected products
cpe fedoraproject/fedora · cpe qt/qt

Qt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath (called from QRasterPaintEngine::fill and QPaintEngineEx::stroke).

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe fedoraproject/fedora35
  • cpe fedoraproject/fedora36
  • cpe qt/qt< 5.15.6
  • cpe qt/qt>= 6.0.0, <= 6.1.2

How to fix CVE-2021-38593

  • Upgrade

    CVE-2021-38593 lists a fix boundary at 5.15.6. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 5.15.6

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2021-38593. EPSS is 3.00%. Act only if a listed version of Qt 5.x before 5.15.6 is installed.

Which versions are affected?

Compare what you have installed with 35, 36, < 5.15.6, >= 6.0.0, <= 6.1.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-787: Out-of-bounds Write. EPSS 3.00%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Aug 12, 2021 · NIST NVD

    Detected

    Qt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath (called from QRasterPaintEngine::fill and QPaintEngineEx::stroke).

  2. Nov 2, 2026 · NIST NVD

    Updated

    Qt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath (called from QRasterPaintEngine::fill and QPaintEngineEx::stroke).

Sources

  • CVE.orgVulnerability recordCVE-2021-38593

    Official CVE identifier

    cve.org
  • NIST NVDVulnerability recordCVE-2021-38593

    Qt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath (called from QRasterPaintEngine::fill and QPaintEngineEx::stroke).

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • NIST NVDNov 3, 2026