Vulnerability · CVE-2021-46659
MariaDB before 10.7.2 allows an application crash because it does not recognize that SELECT_LEX::nest_level is local to each VIEW.
Published Jan 29, 2022 · catalog updated Jun 17, 2026 · MariaDB before 10.7.2 allows
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2021-46659. EPSS is 0.56%. Act only if a listed version of MariaDB before 10.7.2 allows is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (MariaDB before 10.7.2 allows).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-85748 · Critical
- CVE-2026-85746 · Critical
- CVE-2026-85745 · Medium
- CVE-2026-86047 · High
- CVE-2026-92262 · Critical
- Severity
- Medium5.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.56%
- Remediation
- Version ranges on file
- Affected products
- cpe mariadb/mariadb
MariaDB before 10.7.2 allows an application crash because it does not recognize that SELECT_LEX::nest_level is local to each VIEW.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe mariadb/mariadb< 10.2.42
- cpe mariadb/mariadb< 10.3.33
- cpe mariadb/mariadb< 10.4.23
- cpe mariadb/mariadb< 10.5.14
- cpe mariadb/mariadb< 10.6.6
- cpe mariadb/mariadb< 10.7.2
How to fix CVE-2021-46659
Upgrade
CVE-2021-46659 lists a fix boundary at 10.2.42. Compare the installed build with that boundary before you change production.
Version check
Affected < 10.2.42
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2021-46659. EPSS is 0.56%. Act only if a listed version of MariaDB before 10.7.2 allows is installed.
Which versions are affected?
Compare what you have installed with < 10.2.42, < 10.3.33, < 10.4.23, < 10.5.14, < 10.6.6, < 10.7.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.56%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jan 29, 2022 · Monitored products — high
Detected
MariaDB before 10.7.2 allows an application crash because it does not recognize that SELECT_LEX::nest_level is local to each VIEW.
Jun 17, 2026 · Monitored products — high
Updated
MariaDB before 10.7.2 allows an application crash because it does not recognize that SELECT_LEX::nest_level is local to each VIEW.
Sources
- CVE.orgVulnerability recordCVE-2021-46659
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2021-46659
MariaDB before 10.7.2 allows an application crash because it does not recognize that SELECT_LEX::nest_level is local to each VIEW.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 2, 2026
- Monitored products — highNov 1, 2026