Vulnerability · CVE-2022-23633
CVE-2022-23633 is listed by Action Pack is a framework for handling and responding to web requests..
Published Feb 11, 2022 · catalog updated Jun 17, 2026 · the affected product
Last checked Nov 8, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2022-23633. EPSS is 2.22%. Act only if a listed version of the affected product is installed.
Gaps on this record
- No plain product name is stored. The page cannot tell you which product to check.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-66066 · Unknown · known exploited
- CVE-2026-33658 · Low
- CVE-2026-33202 · Medium
- CVE-2026-33195 · High
- CVE-2026-33176 · Medium
- Severity
- Medium5.9
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.22%
- Remediation
- Version ranges on file
- Affected products
- cpe debian/debian linux · cpe rubyonrails/rails
CVE-2022-23633 is listed by Action Pack is a framework for handling and responding to web requests..
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe debian/debian linux10.0
- cpe debian/debian linux11.0
- cpe rubyonrails/rails< 5.2.6.2
- cpe rubyonrails/rails< 6.0.4.6
- cpe rubyonrails/rails< 6.1.4.6
- cpe rubyonrails/rails< 7.0.2.2
How to fix CVE-2022-23633
Upgrade
CVE-2022-23633 lists a fix boundary at 5.2.6.2. Compare the installed build with that boundary before you change production.
Version check
Affected < 5.2.6.2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2022-23633. EPSS is 2.22%. Act only if a listed version of the affected product is installed.
Which versions are affected?
Compare what you have installed with debian/debian linux 10.0; debian/debian linux 11.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-200: Exposure of Sensitive Information; CWE-212: Improper Removal of Sensitive Information Before Storage or Transfer. EPSS 2.22%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Feb 11, 2022 · Monitored products — high
Detected
CVE-2022-23633 is listed by Action Pack is a framework for handling and responding to web requests..
Jun 17, 2026 · Monitored products — high
Updated
CVE-2022-23633 is listed by Action Pack is a framework for handling and responding to web requests..
Sources
- CVE.orgVulnerability recordCVE-2022-23633
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2022-23633
Action Pack is a framework for handling and responding to web requests. Under certain circumstances response bodies will not be closed. In the event a response is *not* notified of a , will not know to reset thread local state for the next request. This can lead to data being leaked to subsequent requests.This has been fixed in Rails 7.0.2.1, 6.1.4.5, 6.0.4.5, and 5.2.6.1. Upgrading is highly reco
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 8, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 8, 2026
- Monitored products — highNov 8, 2026