Vulnerability · CVE-2022-26969
In Directus before 9.7.0, the default settings of CORS_ORIGIN and CORS_ENABLED are true.
Published Dec 26, 2022 · catalog updated Jun 17, 2026 · In Directus before 9.7.0,
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2022-26969. EPSS is 1.00%. Act only if a listed version of In Directus before 9.7.0, is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In Directus before 9.7.0,).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-39943 · Medium
- CVE-2026-39942 · High
- CVE-2026-35442 · High
- CVE-2026-35441 · Medium
- CVE-2026-35413 · Medium
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.00%
- Remediation
- Version ranges on file
- Affected products
- cpe monospace/directus
In Directus before 9.7.0, the default settings of CORS_ORIGIN and CORS_ENABLED are true.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe monospace/directus< 9.7.0
How to fix CVE-2022-26969
Upgrade
CVE-2022-26969 lists a fix boundary at 9.7.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 9.7.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2022-26969. EPSS is 1.00%. Act only if a listed version of In Directus before 9.7.0, is installed.
Which versions are affected?
Compare what you have installed with < 9.7.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-942: Permissive Cross-domain Policy with Untrusted Domains. EPSS 1.00%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 26, 2022 · Monitored products — high
Detected
In Directus before 9.7.0, the default settings of CORS_ORIGIN and CORS_ENABLED are true.
Jun 17, 2026 · Monitored products — high
Updated
In Directus before 9.7.0, the default settings of CORS_ORIGIN and CORS_ENABLED are true.
Sources
- CVE.orgVulnerability recordCVE-2022-26969
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2022-26969
In Directus before 9.7.0, the default settings of CORS_ORIGIN and CORS_ENABLED are true.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 4, 2026