Vulnerability · CVE-2022-31367
Strapi before 3.6.10 and 4.x before 4.1.10 mishandles hidden attributes within admin API responses.
Published Sep 27, 2022 · catalog updated Jun 17, 2026 · Strapi before 3.6.10 and
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2022-31367. EPSS is 1.72%. Act only if a listed version of Strapi before 3.6.10 and is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Strapi before 3.6.10 and).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-57997 · Medium
- CVE-2026-27886 · Critical
- CVE-2026-22707 · Medium
- CVE-2025-64526 · Medium
- CVE-2026-22706 · Low
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.72%
- Remediation
- Version ranges on file
- Affected products
- cpe strapi/strapi
Strapi before 3.6.10 and 4.x before 4.1.10 mishandles hidden attributes within admin API responses.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe strapi/strapi< 3.6.10
- cpe strapi/strapi< 4.1.10
How to fix CVE-2022-31367
Upgrade
CVE-2022-31367 lists a fix boundary at 3.6.10. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.6.10
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2022-31367. EPSS is 1.72%. Act only if a listed version of Strapi before 3.6.10 and is installed.
Which versions are affected?
Compare what you have installed with < 3.6.10, < 4.1.10. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-89: SQL Injection. EPSS 1.72%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Sep 27, 2022 · Monitored products — high
Detected
Strapi before 3.6.10 and 4.x before 4.1.10 mishandles hidden attributes within admin API responses.
Jun 17, 2026 · Monitored products — high
Updated
Strapi before 3.6.10 and 4.x before 4.1.10 mishandles hidden attributes within admin API responses.
Sources
- CVE.orgVulnerability recordCVE-2022-31367
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2022-31367
Strapi before 3.6.10 and 4.x before 4.1.10 mishandles hidden attributes within admin API responses.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 4, 2026