Vulnerability · CVE-2022-32088
MariaDB v10.2 to v10.7 was discovered to contain a segmentation fault via the component Exec_time_tracker::get_loops/Filesort_tracker::report_use/filesort.
Published Jul 1, 2022 · catalog updated Jun 17, 2026 · MariaDB v10.2 to v10.7
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2022-32088. EPSS is 2.02%. Act only if a listed version of MariaDB v10.2 to v10.7 is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (MariaDB v10.2 to v10.7).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-85748 · Critical
- CVE-2026-85746 · Critical
- CVE-2026-85745 · Medium
- CVE-2026-86047 · High
- CVE-2026-92262 · Critical
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.02%
- Remediation
- Version ranges on file
- Affected products
- cpe mariadb/mariadb
MariaDB v10.2 to v10.7 was discovered to contain a segmentation fault via the component Exec_time_tracker::get_loops/Filesort_tracker::report_use/filesort.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe mariadb/mariadb< 10.2.44
- cpe mariadb/mariadb< 10.3.35
- cpe mariadb/mariadb< 10.4.25
- cpe mariadb/mariadb< 10.5.16
- cpe mariadb/mariadb< 10.6.8
- cpe mariadb/mariadb< 10.7.4
How to fix CVE-2022-32088
Upgrade
CVE-2022-32088 lists a fix boundary at 10.2.44. Compare the installed build with that boundary before you change production.
Version check
Affected < 10.2.44
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2022-32088. EPSS is 2.02%. Act only if a listed version of MariaDB v10.2 to v10.7 is installed.
Which versions are affected?
Compare what you have installed with < 10.2.44, < 10.3.35, < 10.4.25, < 10.5.16, < 10.6.8, < 10.7.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 2.02%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 1, 2022 · Monitored products — high
Detected
MariaDB v10.2 to v10.7 was discovered to contain a segmentation fault via the component Exec_time_tracker::get_loops/Filesort_tracker::report_use/filesort.
Jun 17, 2026 · Monitored products — high
Updated
MariaDB v10.2 to v10.7 was discovered to contain a segmentation fault via the component Exec_time_tracker::get_loops/Filesort_tracker::report_use/filesort.
Sources
- CVE.orgVulnerability recordCVE-2022-32088
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2022-32088
MariaDB v10.2 to v10.7 was discovered to contain a segmentation fault via the component Exec_time_tracker::get_loops/Filesort_tracker::report_use/filesort.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 2, 2026
- Monitored products — highNov 1, 2026