Vulnerabilities

Vulnerability · CVE-2022-34382

Dell Command Update, Dell Update and Alienware Update versions prior to 4.6.0 contains a Local Privilege Escalation Vulnerability in the custom catalog configuration.

Published Sep 2, 2022 · catalog updated Nov 2, 2026 · alienware update

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2022-34382. EPSS is 0.19%. Act only if a listed version of alienware update is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
High7.8
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.19%
Remediation
Version ranges on file
Affected products
cpe dell/alienware update · cpe dell/command update · cpe dell/update

Dell Command Update, Dell Update and Alienware Update versions prior to 4.6.0 contains a Local Privilege Escalation Vulnerability in the custom catalog configuration. A local malicious user may potentially exploit this vulnerability in order to elevate their privileges.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe dell/alienware update< 4.6.0
  • cpe dell/command update< 4.6.0
  • cpe dell/update< 4.6.0

How to fix CVE-2022-34382

  • Upgrade

    CVE-2022-34382 lists a fix boundary at 4.6.0. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 4.6.0

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2022-34382. EPSS is 0.19%. Act only if a listed version of alienware update is installed.

Which versions are affected?

Compare what you have installed with dell/alienware update < 4.6.0; dell/command update < 4.6.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.19%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Sep 2, 2022 · NIST NVD

    Detected

    Dell Command Update, Dell Update and Alienware Update versions prior to 4.6.0 contains a Local Privilege Escalation Vulnerability in the custom catalog configuration. A local malicious user may potentially exploit this vulnerability in order to elevate their privileges.

  2. Nov 2, 2026 · NIST NVD

    Updated

    Dell Command Update, Dell Update and Alienware Update versions prior to 4.6.0 contains a Local Privilege Escalation Vulnerability in the custom catalog configuration. A local malicious user may potentially exploit this vulnerability in order to elevate their privileges.

Sources

  • CVE.orgVulnerability recordCVE-2022-34382

    Official CVE identifier

    cve.org
  • NIST NVDVulnerability recordCVE-2022-34382

    Dell Command Update, Dell Update and Alienware Update versions prior to 4.6.0 contains a Local Privilege Escalation Vulnerability in the custom catalog configuration. A local malicious user may potentially exploit this vulnerability in order to elevate their privileges.

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • NIST NVDNov 3, 2026