Vulnerabilities

Vulnerability · CVE-2022-34917

A security vulnerability has been identified in Apache Kafka.

Published Sep 20, 2022 · catalog updated Jun 17, 2026 · A security vulnerability has

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2022-34917. EPSS is 1.48%. Act only if a listed version of A security vulnerability has is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (A security vulnerability has).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.48%
Remediation
Version ranges on file
Affected products
cpe apache/kafka

A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection to a broker can trigger the issue. - Kafka cluster with SASL authentication: Any clients able to establish a network connection to a broker, without the need for valid SASL credentials, can trigger the issue. - Kafka cluster with TLS authentication: Only clients able to successfully authenticate via TLS can trigger the issue. We advise the users to upgrade the Kafka installations to one of the 3.2.3, 3.1.2, 3.0.2, 2.8.2 versions.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe apache/kafka< 2.8.2
  • cpe apache/kafka< 3.0.2
  • cpe apache/kafka< 3.1.2
  • cpe apache/kafka< 3.2.3

How to fix CVE-2022-34917

  • Upgrade

    CVE-2022-34917 lists a fix boundary at 2.8.2. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 2.8.2

  • Advisory

    Open the inventory_high record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2022-34917. EPSS is 1.48%. Act only if a listed version of A security vulnerability has is installed.

Which versions are affected?

Compare what you have installed with < 2.8.2, < 3.0.2, < 3.1.2, < 3.2.3. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-770: Allocation of Resources Without Limits or Throttling; CWE-789. EPSS 1.48%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Sep 20, 2022 · Monitored products — high

    Detected

    A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection

  2. Jun 17, 2026 · Monitored products — high

    Updated

    A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection

Sources

  • Monitored products — highVendor advisoryCVE-2022-34917

    A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • Monitored products — highNov 2, 2026