Vulnerabilities

Vulnerability · CVE-2022-35698

Adobe Commerce versions 2.4.4-p1 (and earlier) and 2.4.5 (and earlier) are affected by a Stored Cross-site Scripting vulnerability.

Published Oct 14, 2022 · catalog updated Jun 17, 2026 · Adobe Commerce versions 2.4.4-p1

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check this week

CVE-2022-35698 is not in CISA KEV. FIRST estimates a 14.68% chance of exploitation in the next 30 days. Check whether you run Adobe Commerce versions 2.4.4-p1.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Adobe Commerce versions 2.4.4-p1).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
14.68%
Remediation
Version ranges on file
Affected products
cpe adobe/commerce · cpe adobe/magento open source

Adobe Commerce versions 2.4.4-p1 (and earlier) and 2.4.5 (and earlier) are affected by a Stored Cross-site Scripting vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe adobe/commerce2.4.4
  • cpe adobe/commerce2.4.5
  • cpe adobe/commerce< 2.4.4
  • cpe adobe/magento open source2.4.4
  • cpe adobe/magento open source< 2.4.4

How to fix CVE-2022-35698

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

CVE-2022-35698 is not in CISA KEV. FIRST estimates a 14.68% chance of exploitation in the next 30 days. Check whether you run Adobe Commerce versions 2.4.4-p1.

Which versions are affected?

Compare what you have installed with adobe/magento open source 2.4.4; adobe/magento open source < 2.4.4. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-79: Cross-site Scripting (XSS). EPSS 14.68%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 14, 2022 · Monitored products — high

    Detected

    Adobe Commerce versions 2.4.4-p1 (and earlier) and 2.4.5 (and earlier) are affected by a Stored Cross-site Scripting vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.

  2. Jun 17, 2026 · Monitored products — high

    Updated

    Adobe Commerce versions 2.4.4-p1 (and earlier) and 2.4.5 (and earlier) are affected by a Stored Cross-site Scripting vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.

Sources

  • CVE.orgVulnerability recordCVE-2022-35698

    Official CVE identifier

    cve.org
  • Monitored products — highVendor advisoryCVE-2022-35698

    Adobe Commerce versions 2.4.4-p1 (and earlier) and 2.4.5 (and earlier) are affected by a Stored Cross-site Scripting vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — highNov 3, 2026