Vulnerabilities

Vulnerability · CVE-2022-36107

CVE-2022-36107 is listed by TYPO3 is an open source PHP based web content management system released under the GNU GPL..

Published Sep 13, 2022 · catalog updated Jun 17, 2026 · the affected product

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2022-36107. EPSS is 0.93%. Act only if a listed version of the affected product is installed.

Gaps on this record

  • No plain product name is stored. The page cannot tell you which product to check.
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.93%
Remediation
Version ranges on file
Affected products
cpe typo3/typo3

CVE-2022-36107 is listed by TYPO3 is an open source PHP based web content management system released under the GNU GPL..

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe typo3/typo3>= 10.0.0, <= 10.4.31
  • cpe typo3/typo3>= 11.0.0, <= 11.5.15
  • cpe typo3/typo3>= 7.0.0, <= 7.6.57
  • cpe typo3/typo3>= 8.0.0, <= 8.7.47
  • cpe typo3/typo3>= 9.0.0, <= 9.5.36

How to fix CVE-2022-36107

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2022-36107. EPSS is 0.93%. Act only if a listed version of the affected product is installed.

Which versions are affected?

Compare what you have installed with >= 10.0.0, <= 10.4.31, >= 11.0.0, <= 11.5.15, >= 7.0.0, <= 7.6.57, >= 8.0.0, <= 8.7.47, >= 9.0.0, <= 9.5.36. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-79: Cross-site Scripting (XSS). EPSS 0.93%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

No dated events have been recorded yet.

Sources

  • CVE.orgVulnerability recordCVE-2022-36107

    Official CVE identifier

    cve.org
  • Monitored products — highVendor advisoryCVE-2022-36107

    TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the (backend and frontend context) is vulnerable to cross-site scripting when malicious files are displayed using this component. A valid backend user account is needed to exploit this vulnerability. Update to TYPO3 version 7.6.58 ELTS, 8.7.48 ELTS, 9.5.37 ELTS, 10.4.32 or 11.5.1

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • Monitored products — highNov 4, 2026