Vulnerability · CVE-2022-40604
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
Published Sep 21, 2022 · catalog updated Jun 17, 2026 · In Apache Airflow 2.3.0
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2022-40604. EPSS is 2.08%. Act only if a listed version of In Apache Airflow 2.3.0 is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In Apache Airflow 2.3.0).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-82355 · Medium
- CVE-2026-75158 · Medium
- CVE-2026-86473 · Critical
- CVE-2026-68971 · Medium
- CVE-2026-68970 · Medium
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.08%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/airflow
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/airflow>= 2.3.0, <= 2.3.4
How to fix CVE-2022-40604
Upgrade
CVE-2022-40604 lists a fix boundary at 2.3.4. Compare the installed build with that boundary before you change production.
Version check
Affected <= 2.3.4
Advisory
Open the inventory_high record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2022-40604. EPSS is 2.08%. Act only if a listed version of In Apache Airflow 2.3.0 is installed.
Which versions are affected?
Compare what you have installed with >= 2.3.0, <= 2.3.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-134: Format String Vulnerability. EPSS 2.08%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Sep 21, 2022 · Monitored products — high
Detected
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
Jun 17, 2026 · Monitored products — high
Updated
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
Sources
- Monitored products — highVendor advisoryCVE-2022-40604
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Monitored products — highNov 2, 2026