Vulnerabilities

Vulnerability · CVE-2022-51026

Bytebase vulnerable to Improper Authentication

Published Mar 2, 2026 · catalog updated Oct 29, 2026 · Bytebase vulnerable to Improper

Last checked Oct 29, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2022-51026. EPSS is 0.61%. Act only if a listed version of Bytebase vulnerable to Improper is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Bytebase vulnerable to Improper).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Critical9.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.61%
Remediation
Advisory link
Affected products
Go github.com/bytebase/bytebase · vendor bytebase

Bytebase 0.12.0 before 1.0.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to log in as any user. The flaw stems from trusting client-supplied GitLab provider configuration in the POST /api/auth/login/GITLAB_SELF_HOST endpoint. Attackers can set instanceUrl to a server they control that returns an active user with a chosen email. Bytebase then issues session tokens for that principal, letting attackers impersonate existing users including the Owner or create new members.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Go github.com/bytebase/bytebase0 → 1.0.1
  • vendor bytebaseversion unspecified

How to fix CVE-2022-51026

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2022-51026. EPSS is 0.61%. Act only if a listed version of Bytebase vulnerable to Improper is installed.

Which versions are affected?

Compare what you have installed with 0 → 1.0.1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-287: Improper Authentication. EPSS 0.61%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Mar 2, 2026 · Go Vulnerability Database

    Detected

    ### Impact - GitLab login allows login by any user. - JWT auth token can be derived as long as the server isn't rebooted. - Developers can assign issues to non-admin/DBA users.

  2. Oct 23, 2026 · Go Vulnerability Database

    Fix available

    github.com/bytebase/bytebase fixed in 1.0.1

  3. Oct 23, 2026 · Go Vulnerability Database

    Fix available

    github.com/bytebase/bytebase fixed in 1.0.1

  4. Oct 23, 2026 · Go Vulnerability Database

    Updated

    ### Impact - GitLab login allows login by any user. - JWT auth token can be derived as long as the server isn't rebooted. - Developers can assign issues to non-admin/DBA users.

  5. Oct 29, 2026 · EUVD

    Updated

    Bytebase 0.12.0 before 1.0.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to log in as any user. The flaw stems from trusting client-supplied GitLab provider configuration in the POST /api/auth/login/GITLAB_SELF_HOST endpoint. Attackers can set instanceUrl to a server they control that returns an active user with a chosen email. Bytebase then issues session

Sources

  • CVE.orgVulnerability recordCVE-2022-51026

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2022-51026

    30-day exploitation probability 0.61%

    first.org
  • EUVDVulnerability recordEUVD-2022-56076

    Bytebase 0.12.0 before 1.0.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to log in as any user. The flaw stems from trusting client-supplied GitLab provider configuration in the POST /api/auth/login/GITLAB_SELF_HOST endpoint. Attackers ca

    euvd.enisa.europa.eu
  • GitHub Advisory DatabasePackage advisoryGHSA-5r3p-6rj5-7937

    GitHub Advisory Database record mirrored by OSV.

    github.com
  • Go Vulnerability DatabasePackage advisoryGHSA-5r3p-6rj5-7937

    Bytebase vulnerable to Improper Authentication

    osv.dev
  • OpenSSF OSV / OSV ScannerPackage advisoryGHSA-5r3p-6rj5-7937

    Bytebase vulnerable to Improper Authentication

    osv.dev

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 29, 2026
  • EUVDOct 29, 2026
  • Go Vulnerability DatabaseOct 24, 2026
  • GitHub Advisory DatabaseOct 23, 2026
  • OpenSSF OSV / OSV ScannerOct 23, 2026
  • CVE.orgOct 23, 2026