Security fix · CVE-2023-1712
Use of hard-coded, security-relevant constants in deepset-ai/haystack
Published Mar 30, 2023 · catalog updated Oct 27, 2026 · Use of hard-coded, security-relevant
Last checked Oct 27, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2023-1712. EPSS is 0.85%. Act only if a listed version of Use of hard-coded, security-relevant is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Use of hard-coded, security-relevant).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.85%
- Remediation
- Advisory link
- Affected products
- PyPI farm-haystack
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack in version 1.15.0 and prior. A patch is available at commit 5fc84904f198de661d5b933fde756aa922bf09f1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI farm-haystack0 → 1.15.0
How to fix CVE-2023-1712
Upgrade
CVE-2023-1712 lists a fix boundary at 1.15.0. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1.15.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2023-1712. EPSS is 0.85%. Act only if a listed version of Use of hard-coded, security-relevant is installed.
Which versions are affected?
Compare what you have installed with 0 → 1.15.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-547. EPSS 0.85%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Mar 30, 2023 · PyPA Advisory Database
Detected
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack in version 1.15.0 and prior. A patch is available at commit 5fc84904f198de661d5b933fde756aa922bf09f1.
Oct 27, 2026 · PyPA Advisory Database
Fix available
farm-haystack fixed in 1.15.0
Oct 27, 2026 · PyPA Advisory Database
Updated
Use of Hard-coded, Security-relevant Constants in GitHub repository deepset-ai/haystack in version 1.15.0 and prior. A patch is available at commit 5fc84904f198de661d5b933fde756aa922bf09f1.
Sources
- CVE.orgVulnerability recordCVE-2023-1712
Official CVE identifier
cve.org - PyPA Advisory DatabasePackage advisoryGHSA-w7qg-j435-78qw
Use of hard-coded, security-relevant constants in deepset-ai/haystack
osv.dev
References
Freshness
Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 27, 2026
- PyPA Advisory DatabaseOct 27, 2026