Vulnerability · CVE-2023-2017
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositorie…
Published Apr 17, 2023 · catalog updated Oct 24, 2026 · the affected product
Last checked Oct 25, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2023-2017. EPSS is 2.07%. Act only if a listed version of the affected product is installed.
Gaps on this record
- No plain product name is stored. The page cannot tell you which product to check.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-31889 · High
- CVE-2026-31888 · Medium
- CVE-2026-31887 · High
- CVE-2025-67648 · Medium
- CVE-2025-7954 · Medium
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 2.07%
- Remediation
- Version ranges on file
- Affected products
- cpe shopware/shopware
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe shopware/shopware6.5.0.0
- cpe shopware/shopware>= 6.1.0, <= 6.4.20.0
How to fix CVE-2023-2017
Upgrade
CVE-2023-2017 lists a fix boundary at 6.4.20.0. Compare the installed build with that boundary before you change production.
Version check
Affected <= 6.4.20.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2023-2017. EPSS is 2.07%. Act only if a listed version of the affected product is installed.
Which versions are affected?
Compare what you have installed with 6.5.0.0, >= 6.1.0, <= 6.4.20.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-1336: Improper Neutralization of Special Elements Used in a Template Engine; CWE-184; CWE-94: Code Injection. EPSS 2.07%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Apr 17, 2023 · NIST NVD
Detected
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified n
Oct 24, 2026 · NIST NVD
Updated
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified n
Sources
- CVE.orgVulnerability recordCVE-2023-2017
Official CVE identifier
cve.org - NIST NVDVulnerability recordCVE-2023-2017
Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validati
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 24, 2026
- NIST NVDOct 24, 2026