Security fix · CVE-2023-32070
XWiki Platform is a generic wiki platform.
Published May 10, 2023 · catalog updated Oct 28, 2026 · XWiki Platform is a
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2023-32070. EPSS is 0.65%. Act only if a listed version of XWiki Platform is a is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (XWiki Platform is a).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.65%
- Remediation
- Version ranges on file
- Affected products
- cpe xwiki/rendering · cpe xwiki/xwiki
XWiki Platform is a generic wiki platform. Prior to version 14.6-rc-1, HTML rendering didn't check for dangerous attributes/attribute values. This allowed cross-site scripting (XSS) attacks via attributes and link URLs, e.g., supported in XWiki syntax. This has been patched in XWiki 14.6-rc-1. There are no known workarounds apart from upgrading to a fixed version.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe xwiki/rendering3.0
- cpe xwiki/xwiki<= 14.5
How to fix CVE-2023-32070
Upgrade
CVE-2023-32070 lists a fix boundary at 14.5. Compare the installed build with that boundary before you change production.
Version check
Affected <= 14.5
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2023-32070. EPSS is 0.65%. Act only if a listed version of XWiki Platform is a is installed.
Which versions are affected?
Compare what you have installed with 3.0, <= 14.5. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-79: Cross-site Scripting (XSS); CWE-83. EPSS 0.65%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
May 10, 2023 · NIST NVD
Detected
XWiki Platform is a generic wiki platform. Prior to version 14.6-rc-1, HTML rendering didn't check for dangerous attributes/attribute values. This allowed cross-site scripting (XSS) attacks via attributes and link URLs, e.g., supported in XWiki syntax. This has been patched in XWiki 14.6-rc-1. There are no known workarounds apart from upgrading to a fixed version.
Oct 28, 2026 · NIST NVD
Updated
XWiki Platform is a generic wiki platform. Prior to version 14.6-rc-1, HTML rendering didn't check for dangerous attributes/attribute values. This allowed cross-site scripting (XSS) attacks via attributes and link URLs, e.g., supported in XWiki syntax. This has been patched in XWiki 14.6-rc-1. There are no known workarounds apart from upgrading to a fixed version.
Sources
- CVE.orgVulnerability recordCVE-2023-32070
Official CVE identifier
cve.org - NIST NVDVulnerability recordCVE-2023-32070
XWiki Platform is a generic wiki platform. Prior to version 14.6-rc-1, HTML rendering didn't check for dangerous attributes/attribute values. This allowed cross-site scripting (XSS) attacks via attributes and link URLs, e.g., supported in XWiki syntax. This has been patched in XW
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 29, 2026
- NIST NVDOct 28, 2026