Vulnerability · CVE-2023-50783
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable.
Published Dec 21, 2023 · catalog updated Jun 17, 2026 · Apache Airflow, versions before
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2023-50783. EPSS is 1.39%. Act only if a listed version of Apache Airflow, versions before is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Apache Airflow, versions before).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-82355 · Medium
- CVE-2026-75158 · Medium
- CVE-2026-86473 · Critical
- CVE-2026-68971 · Medium
- CVE-2026-68970 · Medium
- Severity
- Medium6.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.39%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/airflow
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/airflow< 2.8.0
How to fix CVE-2023-50783
Upgrade
CVE-2023-50783 lists a fix boundary at 2.8.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.8.0
Advisory
Open the inventory_high record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2023-50783. EPSS is 1.39%. Act only if a listed version of Apache Airflow, versions before is installed.
Which versions are affected?
Compare what you have installed with < 2.8.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-284: Improper Access Control. EPSS 1.39%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 21, 2023 · Monitored products — high
Detected
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue
Jun 17, 2026 · Monitored products — high
Updated
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue
Sources
- Monitored products — highVendor advisoryCVE-2023-50783
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Monitored products — highNov 2, 2026